Results 1 to 8 of 8

Thread: TP-Link TL-WN821N & TL-WN722N not entering monitor mode =(

  1. #1
    Join Date
    2018-Jul
    Location
    Johannesburg, South Africa
    Posts
    1

    Angry TP-Link TL-WN821N & TL-WN722N not entering monitor mode =(

    Hey there, hope someone can help me, I've been a Kali user and abuser for a little over a year now, not a noob, but not a great magic worker either, I can kinda hold my own and get by, cause it's Linux.
    Now, the problem I have is this, it's drivers for wifi dongles.
    You see, here is the question though, when wi-fi hacking, I have 2 different TP-Link adapters that have, Ralink chipsets in them, the TP-Link TL-WN722N v5 and the TP-Link TL-WN821N and for no love or toiling sweat or forum searching have I been able to find a way to get these b@$t@rd$ to go into monitor mode, if I can get Kali to recognize them at all.
    Please see below:
    https://imgur.com/a/vwKKUkZ

    Here's the thing about the forums, they just shuffle you off to download a GitHub G++ make driver, and when I do that, still nothing, I can see the wi-fi adapter, it can catch wi-fi, but it will not switch to monitor mode.
    I have an Atheros chipset in my PCIe wireless card, which Kali picks up on initial install, which goes into monitor mode quite happily, but not the TP-Link adapters...
    Am I doing something wrong?
    Does Kali just not like Ralink chipsets?
    Cause this is really grinding my gears...
    Be authentic to your dreams. Be authentic to your own idea about
    yourself. Grind away at your own minds and bodies until you become your
    own invention. Be Mad Scientists. ~ Doktor Sleepless

  2. #2
    Join Date
    2018-Aug
    Posts
    6
    If I am not mistaken the TP-Link WN722N has to be V1 for it to be compatible with monitor mode and packet injection.

  3. #3
    Join Date
    2017-Jan
    Posts
    27
    @Raisedfist.
    I have WN722N V2. it works in monitor mode. Not sure about V5.
    You might want to try using the IWCONFIG to get into monitor mode instead Airmon-ng.

    TC.

  4. #4
    Join Date
    2018-Sep
    Posts
    6
    *EDITED*
    Comment Removed.
    Last edited by Ne'eman; 2018-09-04 at 01:42.

  5. #5
    Join Date
    2016-Dec
    Posts
    431
    A few things:

    - echo 1 > /proc/sys/net/ipv4/ip_forward is not needed. It is used when setting up linux as a router (1 will tell the kernel to forward packets, 0 will disable that; then you use iptables to set-up the forwarding between interfaces). Ne'eman, you are incorrect in your explanation, it has nothing to do with wireless connectivity
    - What is the version of the TP-Link TL-WN821N?
    - Could you paste lsusb output?
    - You need, as stated on the main page of aircrack-ng, kill the network managers BEFORE putting the card in monitor mode as they can interfere with monitor mode and change channels
    - I'm pretty sure the driver is already in the kernel
    - Next time, please paste the text from the picture instead of linking the picture in a code block
    - Did you test plugging the adapters and running airmon-ng without any arguments to see if they were shown? Most of the time, drivers are already in the kernel.

  6. #6
    Join Date
    2018-Aug
    Posts
    6
    As bchuck said.you should buy a WN722N-V1

  7. #7
    Join Date
    2016-Dec
    Posts
    431
    Or AWUS036NHA

  8. #8
    Join Date
    2018-Jul
    Location
    Hungary
    Posts
    17
    the 821n can turn into monitor mode but the raspberry didn't recognize the driver and if try to manualy install it the makefile didn't recognize the distribution

Similar Threads

  1. TP-Link TL-WN722N V2 Monitor mode
    By Barbeek in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2017-12-18, 06:13

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •