I created a Kali linux SD card sometime ago and everything was working just fine. Long story short, I had to make a new image recently. The site is different and has way more options for Raspberry pi than before. I have tried 3 different images, two different cards and, receive the same error every time.

On a fresh install I preform the following commands with zero issues:
apt-get update
apt-get install kali-linux-full
Once I run
apt-get dist-upgrade
apt-get upgrade
I receive the same error at the very end. Below you can find the output I'm receiving.

Setting up raspi3-firmware (1.20180619-1) ...
Error: missing /boot/firmware, did you forget to mount it?
dpkg: error processing package raspi3-firmware (--configure)
installed raspi3-firmware package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:

I always just used the images in the past from the downloads section, then used "ApplePi-Baker". From there I always use the "prep for noobs" to format the card then I import the image to the card. In the past never had any issues. Raspberry pi 3 b. I appreciate any info you may have.