Hey there,

I've been trying everything I found on the net for hours but can't get my Kali Linux Live USB flashdrive (using the KDE image) to work on Windows 10 with UEFI booting, even though I disabled secure booting. I always get this error when I try to boot Kali Live from USB.

error: file '/live/vmlinuz-4.17.0-kali3-amd64' not found.
error: you need to load the kernel first
Things I've tried so far:

  1. Using the weekly Kali Linux image instead of the standard one.
  2. Following the steps in this thread, including making my own grub.cfg, excluding downloading the mentioned file because a) the link is broken and b) there already is a file of this name in the newest iso (which obviously was not the case when the thread I used has been started).
  3. I tried to use Universal USB Installer. When it opens 7zip to extract the files, it always crashes while copying /live/filesystem.squashfs because at some point it says this file can not be found.
  4. I tried to use YUMI with the same result.
  5. I tried to use Win32DiskImager which stops at 8 percent, saying the system is unable to find the file (I translated this message from the German version which I am using).
  6. I tried to use Rufus, which crashes early during copying the files in the exact same moment where Windows tries shows the error "There is a problem with this drive"
  7. I thought perhaps the automount feature of Windows is causing all the trouble, which is why I disabled it, which did not change the behaviour of Rufus or Win32DiskImager.
  8. Because of this I extracted the iso, deleted the autorun file, made a new iso and tried to use this. Again, I get the same error nevertheless.
  9. I tried Unetbootin, which is able to extract and copy the iso without any interruption, but results in the error I mentioned above (error: file '/live/vmlinuz-4.17.0-kali3-amd64' not found.)
  10. I tried a different USB drive with the same results.+
  11. I tried different programs and Windows itself to format the USB drive with fat32 before installing the image, but that didn't help neither.

I guess I forgot about some steps I tried in the past hours, but nothing seems to work. Does anybody know a solution I might have missed on my search? Before I forget: Switching to legacy booting is not an option.

Thanks for any advice, kind regards,