Results 1 to 3 of 3

Thread: Installed Kali on external HDD but boot fails (ALERT! /dev/sdc3 does not exist. Dropping a shell)

  1. #1
    Join Date
    2018-Sep
    Posts
    2

    Installed Kali on external HDD but boot fails (ALERT! /dev/sdc3 does not exist. Dropping a shell)

    Hello

    I have installed Kali on my USB hard drive, during the install I have chosen the manual partitioning to install on the usb hdd.
    The install went through without issues.

    When I reboot my mac (with rEFind installed) the kali entry pops up, and goes into that blue Kali screen to chose to boot on it.
    Once it boots it fails at the begining with this error

    [HTML]Gave up waiting for root file system device. Common problems:
    - Boot args (cat /proc/cmdline)
    - Check rootdelay= (did the system wait long enough?)
    - Missing modules (cat /proc/modules: ls /dev)

    ALERT! /dev/sdc3 does not exist. Dropping a shell[/HTML


    During the install though I'm pretty sure I saw the external hdd being called "sdb" and to "sdc"

    Why did this happen? How can I debug / fix this ?

    Thanks!

  2. #2
    Join Date
    2018-Sep
    Posts
    2
    Update:

    Just noticed it strangely tried to load sdc3??
    I had clearly set the root device to be /dev/sdb3 during the install, why is it trying to load sdc ?

    I have entered 'e' to configure GRUB and tried changing on the fly the root target and it boots Kali just fine.



  3. #3
    Join Date
    2016-Dec
    Posts
    307
    I haven't done this in years but my guess is that the disk is going to be called sda, so in this case just edit the boot drive.

    It was called sdc because you had 2 disks on the system when you installed it and this one was the third one at the time.

Similar Threads

  1. Unable to boot Kali installed on external HDD
    By mikev1 in forum Installing Archive
    Replies: 1
    Last Post: 2016-02-27, 06:12
  2. Replies: 0
    Last Post: 2015-01-08, 23:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •