Results 1 to 3 of 3

Thread: kali-linux-full metapackage installation blocked by cisco-global-exploiter package

  1. #1
    Join Date
    2018-Oct
    Posts
    2

    kali-linux-full metapackage installation blocked by cisco-global-exploiter package

    Hello, everyone.

    I am currently trying to install Kali 2018.3 onto my Raspberry Pi 3B. The base OS installation went fine (of course, it simply involves dropping the downloaded image onto an SD card which Rufus is very good at), and I have done an update (which also worked OK once I found the thread about the raspi3-firmware package problem).

    With the base Kali OS up and running, I would like to populate it with all of the tools. To that end, I am trying to run:

    apt-get install kali-linux-full

    This starts to run, and then hangs up when it reaches the cisco-global-exploiter package. I have left it to run for over an hour in the hopes that it would eventually sort itself out, but it does not. Once the message shown in the following screenshot appears, it just continues to refresh with the same message about once per second.


    Screenshot-WaitingForCEG by stoooo, on Flickr

    I tried to put the problem package on hold, but that just breaks dependencies and stops the process completely, as shown below.


    Screenshot-FailedDependencies by stoooo, on Flickr

    I then tried to see if there was a problem with the file on my local mirror. As it happens, I am unable to access the file cisco-global-exploiter_13-1kali3_all.deb on all of the mirrors that I tried:

    http://http.kali.org/pool/main/c/cis...bal-exploiter/
    http://ftp.hands.com/kali/pool/main/...bal-exploiter/ (My default mirror)
    http://ftp.halifax.rwth-aachen.de/ka...bal-exploiter/
    http://mirrors.ocf.berkeley.edu/kali...bal-exploiter/
    http://mirror.serverius.net/kali/poo...bal-exploiter/

    I can access the other three files in the folder without issue, but every instance of the .deb file causes the following error in Firefox when I click on it:


    KaliCGEConnectionProblem by stoooo, on Flickr

    Does this point to some sort of permissions problem on the one file in the repositories? I can access other .deb files in different directories without any issues. If this was causing problems for more people than just me, surely my searches on Google this morning would have found some reference to it. I have seen other people discussing difficulties with the kali-linux-full metapackage over the years, but no mention of this specific package in relation to it.

    Can anyone help me find a way around this problem so that I can get all of the tools onto my Pi?

    Thanks.

  2. #2
    Join Date
    2018-Oct
    Posts
    2
    I think I've found my problem. After trying to access the file from the Pi itself, and from a Win10 PC, I started to wonder if maybe there was a network issue going on at my end. I switched my phone from WiFi to 4G, and was able to download the file just fine.

    Then I checked my firewall logs, and found that it was blocking the file due to it containing a virus. On the one hand, I'm glad that my firewall is doing its job. On the other, it seems strange that this one file would be flagged. Looking on VirusTotal, 18/58 AV engines flag it as malware.

    https://www.virustotal.com/#/file/10...b217/detection

    I understand that many of the tools available in Kali could be considered malware depending on how they are used. It just seems oddly specific in this instance. For now, I have added a VPN to the Pi so as to bypass the firewall protections while I add the tools in kali-linux-full.

    Sorry for the false alarm.

  3. #3
    Join Date
    2016-Dec
    Posts
    372
    A reason why a package doesn't exist anymore is because it was updated. Make sure to run apt-get update updating the system (apt dist-upgrade). Remove the hold before running both of these commands.

Similar Threads

  1. Installing kali-linux-full metapackage..
    By BazzaBoiii in forum Installing Archive
    Replies: 0
    Last Post: 2014-09-11, 21:56
  2. Replies: 0
    Last Post: 2014-02-01, 15:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •