Hello all, first post on the forum. I combed through previous posts and didn't see the solution to this, although I'm burned out from troubleshooting so please forgive me if this turns out being a duplicate post.

I am running Kali Linux for WSL, just installed yesterday, performed update && dist-upgrade, apt-get bash-completion and then sudo apt-get install webshells. For anti-virus, I am running FireEye endpoint security with Windows Defender underneath. The primary complaint/error I get installing webshells is "unable to install new version of" and then "unable to securely remove" '/usr/share/webshells/asp/cmd-asp-5.1-asp': Permission Denied.This is running Kali from the start menu "as administrator" and using both sudo and su - neither work. I am not getting any antivirus warnings as the videos on Kali website suggest might be appropriate at this point of installation. Nonetheless, I added "C:\Users\admin\AppData\Local\Packages\KaliLinux.5 4290C8133FEE_ey8k8hqnwqnmg" as an exception in Defender, but has no effect. I tried sudo chmod -R 777 ./asp/ but still no luck after permissions were opened up.

Any idea what might be happening here? My sense is FireEye, but no idea how to get around it. I've emailed their support team too so will post here if I find anything out. I actually tried uninstalling FireEye but it wants an install password that it never asked me to define, so looks like I am stuck with it unless a complete system rebuild.

Any help appreciated!!!!