Results 1 to 3 of 3

Thread: Strange error while im updating my kali

  1. #1
    Join Date
    2018-Nov
    Posts
    2

    Question Strange error while im updating my kali

    Hello everyone,

    Sorry, I'm a newbie in Linux and my first time to use an OS like this. I hope this is a valid post.

    By the way here is the info of my kali:

    No LSB modules are available.
    Distributor ID: Kali
    Description: Kali GNU/Linux Rolling
    Release: kali-rolling
    Codename: kali-rolling
    OS Type: 64bit
    Version: 4.18.0-kali2-amd64

    ***My Repository***

    #The Kali Repository
    #deb http://repo.kali.org/kali kali-rolling main contrib non-free
    # For source package access, uncomment the following line
    # deb-src http://repo.kali.org/kali kali-rolling main contrib non-free
    # deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL #Binary 20160830-11:29]/ kali-rolling contrib main non-free
    #deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL #Binary 20160830-11:29]/ kali-rolling contrib main non-free
    deb http://http.kali.org/kali kali-rolling main non-free contrib


    Other repositories: (under sources.list.d in a separate text list file) I know these repositories is irrelevant and I just want you to know.
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    #deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

    #deb http://repository.spotify.com stable non-free

    #deb https://download.sublimetext.com/ apt/stable/



    this is my first time to see this kind of error and I don't know if this is an error.

    ***Error I encountered***Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease

    Get:2 http://dl.google.com/linux/chrome/deb stable Release [943 B]
    Get:3 http://dl.google.com/linux/chrome/deb stable Release.gpg [819 B]
    Hit:4 http://repository.spotify.com stable InRelease
    E: Repository 'http://dl.google.com/linux/chrome/deb stable Release' changed its 'Origin' value from 'Google, Inc.' to 'Google LLC'
    N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8)
    manpage for details.
    Do you want to accept these changes and continue updating from this repository? [y/N] y
    Get:6 https://download.sublimetext.com apt/stable/ InRelease [2,562 B]
    Get:7 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1,131 B]
    Get:5 http://ftp.harukasan.org/kali kali-rolling InRelease [30.5 kB]
    Reading package lists... Done
    E: Release file for https://download.sublimetext.com/apt/stable/InRelease is not valid yet (invalid for another 4h 14min 39s). Updates for this repository will not be applied.
    E: Release file for http://http.kali.org/kali/dists/kali-rolling/InRelease is not valid yet (invalid for another 7h 6min 57s). Updates for this repository will not be applied.

    then I wait for 7hr and I commented on my other repository but still the same

    Get:1 http://ftp.harukasan.org/kali kali-rolling InRelease [30.5 kB]
    Reading package lists... Done
    E: Release file for http://http.kali.org/kali/dists/kali-rolling/InRelease is not valid yet (invalid for another 8h 47min 59s). Updates for this repository will not be applied.




    What should I do now? Please help me. Please don't be mad at me if this is an irrelevant post because I don't know where to ask this question.

  2. #2
    Join Date
    2016-Dec
    Posts
    320
    It's not recommended to use other repositories as it will mess up your install sooner or later. Just FYI and next time, mention the commands that produce the error too. In this case, the command is apt-get update.

    It doesn't make sense, apt-get mentions repositories you commented out and it would normally only do this if they're not commented out. If you think this is a bug, then try to reproduce it on a debian system and report it to debian.

    I would strongly recommend to reinstall the system, commenting out repositories after installing software from them will lead to the same issues I mentioned. As an alternative to Chrome, use Chromium, which is available in any linux repository (including Kali).

  3. #3
    Join Date
    2018-Nov
    Posts
    2
    Hello,


    Just a quick update, for some reason the problem that I encountered yesterday is gone and I don't do anything about it.

    ****Here is the output I used sudo apt-get update****

    Get:1 http://ftp.harukasan.org/kali kali-rolling InRelease [30.5 kB]
    Get:2 http://ftp.harukasan.org/kali kali-rolling/non-free Sources [130 kB]
    Get:3 http://ftp.harukasan.org/kali kali-rolling/main Sources [12.3 MB]
    Get:4 http://ftp.harukasan.org/kali kali-rolling/contrib Sources [59.3 kB]
    Get:5 http://ftp.harukasan.org/kali kali-rolling/main i386 Packages [16.5 MB]
    Get:6 http://ftp.harukasan.org/kali kali-rolling/main amd64 Packages [16.6 MB]
    Get:7 http://ftp.harukasan.org/kali kali-rolling/main amd64 Contents (deb) [35.8 MB]
    Get:8 http://ftp.harukasan.org/kali kali-rolling/main i386 Contents (deb) [35.6 MB]
    Get:9 http://ftp.harukasan.org/kali kali-rolling/non-free i386 Packages [161 kB]
    Get:10 http://ftp.harukasan.org/kali kali-rolling/non-free amd64 Packages [174 kB]
    Get:11 http://ftp.harukasan.org/kali kali-rolling/non-free amd64 Contents (deb) [819 kB]
    Get:12 http://ftp.harukasan.org/kali kali-rolling/non-free i386 Contents (deb) [810 kB]
    Get:13 http://ftp.harukasan.org/kali kali-rolling/contrib amd64 Packages [95.5 kB]
    Get:14 http://ftp.harukasan.org/kali kali-rolling/contrib i386 Packages [94.4 kB]
    Get:15 http://ftp.harukasan.org/kali kali-rolling/contrib i386 Contents (deb) [177 kB]
    Get:16 http://ftp.harukasan.org/kali kali-rolling/contrib amd64 Contents (deb) [178 kB]
    Fetched 120 MB in 4min 11s (476 kB/s)
    Reading package lists... Done

    By the way, the only repository I used is http://http.kali.org/kali kali-rolling main non-free contrib (​​from docs.kali.org). Is that correct right?
    The other repositories I commented out is the repositories when my Kali Linux installed for the first time in my very old mac(as my main OS) and I just leave that for some reason. Your suggestion about the chromium, hmm I will try that. Firefox in this machine is very so chrome is just a quick fix for me... hehe

    sorry for my English, I really try to write this at my own very best :-D



    Thanks for the suggest and help.

Similar Threads

  1. Error updating Kali 2.0
    By thiagomespb in forum Installing Archive
    Replies: 0
    Last Post: 2015-08-15, 18:28
  2. Replies: 11
    Last Post: 2015-07-31, 13:37
  3. Strange internet access error only with Kali Linux
    By eurovpn in forum General Archive
    Replies: 1
    Last Post: 2014-11-15, 15:03

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •