Results 1 to 5 of 5

Thread: Linux Kali 4.14.71--V8, Kali-Linux-Full, workguard install error

  1. #1
    Join Date
    2018-Oct
    Posts
    9

    Linux Kali 4.14.71--V8, Kali-Linux-Full, wireguard install error

    I am a newbie and I am not sure where this post belongs.
    I have a raspberry pi 3B+ whcih I installed the 2018.4 Kali-linux 64 bit,
    I did the update and upgrade then I did an apt install kali-linux-full.
    Now I wanted to try the wireguard and I did the apt install wireguard resolvconf as was suggested in a blog by Elwood
    I received and error trying to do the install.
    The terminal showed the following:

    root@kali:~# apt install wireguard resolvconf
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following additional packages will be installed:
    dkms wireguard-dkms wireguard-tools
    Suggested packages:
    python3-apport
    Recommended packages:
    linux-headers-686-pae | linux-headers-amd64 | linux-headers-generic | linux-headers
    The following NEW packages will be installed:
    dkms resolvconf wireguard wireguard-dkms wireguard-tools
    0 upgraded, 5 newly installed, 0 to remove and 2 not upgraded.
    Need to get 493 kB of archives.
    After this operation, 2,375 kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Get:1 http://archive.linux.duke.edu/kalilinux/kali kali-rolling/main arm64 dkms all 2.6.1-1 [74.1 kB]
    Get:2 http://archive.linux.duke.edu/kalilinux/kali kali-rolling/main arm64 resolvconf all 1.79 [74.2 kB]
    Get:3 http://archive.linux.duke.edu/kalilinux/kali kali-rolling/main arm64 wireguard-dkms all 0.0.20180918-1 [228 kB]
    Get:4 http://archive.linux.duke.edu/kalilinux/kali kali-rolling/main arm64 wireguard-tools arm64 0.0.20180918-1 [96.7 kB]
    Get:5 http://archive.linux.duke.edu/kalilinux/kali kali-rolling/main arm64 wireguard all 0.0.20180918-1 [20.1 kB]
    Fetched 493 kB in 2s (306 kB/s)
    Preconfiguring packages ...
    Selecting previously unselected package dkms.
    (Reading database ... 264007 files and directories currently installed.)
    Preparing to unpack .../archives/dkms_2.6.1-1_all.deb ...
    Unpacking dkms (2.6.1-1) ...
    Selecting previously unselected package resolvconf.
    Preparing to unpack .../resolvconf_1.79_all.deb ...
    Unpacking resolvconf (1.79) ...
    Selecting previously unselected package wireguard-dkms.
    Preparing to unpack .../wireguard-dkms_0.0.20180918-1_all.deb ...
    Unpacking wireguard-dkms (0.0.20180918-1) ...
    Selecting previously unselected package wireguard-tools.
    Preparing to unpack .../wireguard-tools_0.0.20180918-1_arm64.deb ...
    Unpacking wireguard-tools (0.0.20180918-1) ...
    Selecting previously unselected package wireguard.
    Preparing to unpack .../wireguard_0.0.20180918-1_all.deb ...
    Unpacking wireguard (0.0.20180918-1) ...
    Setting up wireguard-tools (0.0.20180918-1) ...
    Setting up dkms (2.6.1-1) ...
    Processing triggers for systemd (239-11) ...
    Processing triggers for man-db (2.8.4-3) ...
    Setting up resolvconf (1.79) ...
    update-rc.d: We have no instructions for the resolvconf init script.
    update-rc.d: It looks like a non-network service, we enable it.
    Setting up wireguard-dkms (0.0.20180918-1) ...
    Loading new wireguard-0.0.20180918 DKMS files...
    It is likely that 4.14.71-v8 belongs to a chroot's host
    Building for 4.14.71-v8
    Building initial module for 4.14.71-v8
    Error! Bad return status for module build on kernel: 4.14.71-v8 (aarch64)
    Consult /var/lib/dkms/wireguard/0.0.20180918/build/make.log for more information.
    dpkg: error processing package wireguard-dkms (--configure):
    installed wireguard-dkms package post-installation script subprocess returned error exit status 10
    dpkg: dependency problems prevent configuration of wireguard:
    wireguard depends on wireguard-dkms (= 0.0.20180918-1) | wireguard-modules (>= 0.0.20171001); however:
    Package wireguard-dkms is not configured yet.
    Package wireguard-modules is not installed.

    dpkg: error processing package wireguard (--configure):
    dependency problems - leaving unconfigured
    Processing triggers for systemd (239-11) ...
    Processing triggers for resolvconf (1.79) ...
    Errors were encountered while processing:
    wireguard-dkms
    wireguard
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Thank you for any help and support
    Last edited by retired_techie; 3 Weeks Ago at 21:57. Reason: workguard should be wireguard

  2. #2
    Join Date
    2016-Dec
    Posts
    372
    make sure to have your system up to date before installing it: apt update && apt dist-upgrade then reboot. Let me know how it goes.

  3. #3
    Join Date
    2018-Oct
    Posts
    9
    I wish to have this post closed.
    I went to the 32bit instead of the 64bit Kali which I did not know was a beta version.
    As it turns out the new 2018.4 release,
    or doing the apt update && apt -y full-upgrade
    installs the wireguard so the original help requested is no longer required.
    My solution is to stay with the 32bit until the 64bit is more stable for a newbie like me.
    Problem solved!

  4. #4
    Join Date
    2018-Oct
    Posts
    9
    Quote Originally Posted by Mister_X View Post
    make sure to have your system up to date before installing it: apt update && apt dist-upgrade then reboot. Let me know how it goes.
    Thanks Mister X,
    I did not receive an email and I had not checked this until after I read about the 64 bit being a beta release.
    Thank you again. How do I close this post or change its status to solved?

  5. #5
    Join Date
    2016-Dec
    Posts
    372
    It's experimental, not beta.

Similar Threads

  1. Rpi2 kali-linux-full 64gig sd install error
    By Ianlmt in forum ARM Archive
    Replies: 2
    Last Post: 2017-03-03, 22:25
  2. Replies: 1
    Last Post: 2013-12-31, 08:17

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •