Results 1 to 6 of 6

Thread: Asus USB-AC56 Won't go into monitor mode?

  1. #1
    Join Date
    2018-Nov
    Posts
    5

    Angry Asus USB-AC56 Won't go into monitor mode?

    P_setting_fff_1_90_end_500.jpg

    Hello,

    According to a few different sites the USB-AC56 should be able do go into monitor mode.



    I have Kali installed directly on this laptop (just to make it as easy as possible. I'm just learning).

    I buy the card. First I try the drivers from Asus' site https://www.asus.com/us/Networking/U...Desk_Download/. ./install.sh fails:

    Code:
    : error: ?_timer {aka struct timer_list}? has no member named ?data?  ptimer->data = (unsigned long)cntx;
    Which led me to an askubuntu (https://askubuntu.com/questions/1042...odules-error-2) about a similar error. From the errors in the console I was able to determine that I needed drivers for the rtl8812AU chipset and that, finally, led me to a working driver (https://github.com/diederikdehaas/rtl8812AU/)

    Now I can see and use the USB-AC56! But it won't get into monitor mode . I figure out which one it is by running
    Code:
    iwconfig
    , unplugging it, and running
    Code:
    iwconfig
    again. First I run
    Code:
    iw list
    to see if monitor mode is supported and if I am reading this right, yes it is supported:

    Code:
        Supported interface modes:         * IBSS
             * managed
             * AP
             * monitor
             * mesh point
             * P2P-client
             * P2P-GO
             * P2P-device
    Then I do:

    Code:
    ifconfig wlan1 down
    iwconfig wlan1 mode monitor
    fconfig wlan1 up
    iw list
    and that gives:

    Code:
    wlan1     unassociated  Nickname:"<WIFI@REALTEK>"          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
              Sensitivity:0/0  
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    so it's not in monitor mode. Similiarly, if I select that NIC in Wireshark, then Stop, then Capture Options, then click the monitor mode checkbox it immediately unchecks itself. Can you help a brotha-er out?
    Last edited by unclespam; 2018-11-18 at 15:23.

  2. #2
    Join Date
    2016-Dec
    Location
    Canada
    Posts
    248
    Try these commands one after the other
    airmon-ng

    airmon-ng check kill

    airmon-ng start wlanx ( x being adapter from airmon-ng call)

    If not
    rfkill list all

  3. #3
    Join Date
    2018-Nov
    Posts
    5
    Hi bigbiz, Thank for replying.

    After creating this post I went back at it for a little while. I think I saw some success with
    Code:
    airodump-ng wlan0
    because it said it switched the device to monitor mode and started showing results. Plus wireshark started seeing all wifi traffic so I think it worked. One thing I don't understand is
    Code:
    iwconfig
    shows it as being in Auto mode. I guess Auto mode lets it work in Managed mode (?).

    Code:
    airmon-ng check kill
    shows wpa_supplicant which I killed. I continue following your steps (which at this point may not even be necessary but I'm just following through) and that gives:

    Code:
    root@kali:~# airmon-ng start wlan0
    
    
    
    PHY	Interface	Driver		Chipset
    
    
    phy1	wlan0		8812au		ASUSTek Computer, Inc. 
    
    
    Error setting channel: command failed: Operation not supported (-95)
    
    
    		(mac80211 monitor mode already enabled for [phy1]wlan0 on [phy1]10)

  4. #4
    Join Date
    2018-Nov
    Posts
    5
    Sorry, I need to add some clarity to my previous post but I can't edit it until it's approved. When I "went back at it" I had ran:
    Code:
    sudo pkill wpa_supplicantsudo systemctl stop NetworkManager.service
    which I think was the key (same as you were saying. kill the process that was taking it out of monitor mode).

  5. #5
    Join Date
    2018-Nov
    Posts
    5
    I was wrong. It's still not going in monitor mode even after
    Code:
    airmon-ng check kill
    . It just goes into Auto mode. Any idea about what to try next? I'll keep trying. If I haven't posted an answer that means I still haven't got it in monitor mode. By that I mean iwconfig reports Mode: Monitor.

  6. #6
    Join Date
    2018-Nov
    Posts
    5
    Okay finally I got into monitor mode.

    Step1: return the Asus USB-AC56 to the store! it won't go into monitor mode!
    Step2: order an alfa
    https://www.amazon.com/AWUS036NEH-Range-WIRELESS-802-11b-USBAdapter/dp/B0035OCVO6

    I didn't even have to install any drivers. The alpha went straight into monitor mode plus it was half the cost.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •