Results 1 to 4 of 4

Thread: Hard disk installation issue - Cannot reach GUI login

  1. #1
    Join Date

    Hard disk installation issue - Cannot reach GUI login

    Hey guys,

    So real quick, I'm fairly new to Kali and have only tampered with it in a virtual environment thus far. My major does have an area of concentration on Forensic Analysis, so I decided to run a hard disk install of Kali 2018.4 so that I could reap the benefits of my station's hardware, this and I have quite a few classes and certs coming up that will require me to become more intimate with the system. In doing this I went about the following procedure:

    -downloaded 2018.4 from official site.
    -Created a partition in windows disk management on my 2TB HDD.
    -Used dd option on Rufus3 when imaging ISO to USB.
    -Ran Graphical Install.
    -Manually selected partition previously made, deleted partition to created free space, and allowed Kali to automatically configure that free space for ext4 and swap.
    -Setup a network mirror.
    -set up grub on same HDD.
    -Installation completed and I rebooted the system.

    Following this I tried to launch into Kali GUI and this sends me to a never-ending blackscreen. I never reach the grey screen for root login. I am only able to enter recovery mode and execute commands from there. I'm not sure if there is a hardware issue between the system and my GPU or what. Been at this for 2 days now and originally was trying to place Kali on a WD Black M.2 NVMe before to no success. Found out that these particular SSDs have had issues with Linux systems. This is why I switched to the 7200 HDD. I'll post some system info below and some pics of where I'm at so far.

    -Intel core i7-8700k 3.7GHZ (coffee lake)
    -(2) Corsair 8GB DDR4-300 Vengeance
    -Nvidia Geforce GTX 1080 Ti 11GB GDDR5X
    -2TB HDD 3.5" SATA III 7200RPM
    -Gigabyte Aorus GA-Z370-gaming 5 MOBO

    This is pretty much where I am at right now. I tried to provide the best images that I could.

    Any help on this matter would be greatly appreciated! Thanks Guys!

  2. #2
    Join Date
    I have lots of similar issues, just been playing around really. My system is just a laptop with a WWAN card. No other network access.

    If when I install, I have a wired network connection., that never works. I have to unplug from the network and deny a mirror for updates. Turn off the WWAN card. Shut down with the power switch, and try again. I suspect Kali does a network check for updates prior to starting up fully. I could be wrong on that reason.

    I notice that your recovery_mode pic is asking for the root password. That's how I got it to start up, typed in the password. Let it start in recovery mode. Then manually turned on the WWAN / plugged in the cable.

    Sometimes the system will not start up again from cold with the WWAN switch set differently to how it was powered off, Or plugged into a network when it was unplugged at shut down. An autocheck for a non-existent network connection would explain that.

    Hope this helps you in some way - suggest you try the recovery mode, enter the password. then "systemctl default" and hit Enter to get a desktop (assuming your virtual machine is set to start with a GUI and not just leave you in a shell environment).
    Last edited by NoobLinuxuser; 2018-11-19 at 01:45.

  3. #3
    Join Date
    So everything appears to run smoothly for me on the install. This installation is for a full install on my HDD rather than a virtual machine. The graphical install completes with no problem. When I go to start the OS normal I get black screened and never reach the root login. So far, the only thing I can do is use the OS in recovery mode. I'll have to tinker with it more tonight; I'm thinking that since Recovery Mode is working fine that it must be an issue with not having updated drivers for my GPU. Again, I'm fairly new to the Linux community so I'm really just shooting in the dark.

  4. #4
    Join Date
    ALL FIXED NOW! Simple fix, kinda agitated that I wasted a Saturday night on it. Edited /etc/network/interfaces to obtain IP from DHCP, booted into recovery, upgrade & install, and downloaded Nvidia drivers. Works like a charm! Thanks for the help NoobLinuxuser.

Similar Threads

  1. Plasma not working on Hard disk installation
    By jhowmar in forum Kali Linux TroubleShooting
    Replies: 0
    Last Post: 2018-11-03, 03:24
  2. Installing on external hard disk grub issue
    By Blackshield1 in forum Installing Archive
    Replies: 0
    Last Post: 2015-07-10, 21:08
  3. Phone Mounted as Hard disk issue
    By Jabberwockey in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-12-17, 10:37
  4. Encrypted installation on hard disk easy to crack?
    By pamamolf in forum General Archive
    Replies: 3
    Last Post: 2013-09-19, 16:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts