Results 1 to 2 of 2

Thread: Going on hour 9 of installation. Grub problems

  1. #1

    Going on hour 9 of installation. Grub problems

    I'm pulling my hair out. I try to exhaust my research before asking questions, and I'm at that point.

    I've got a Panasonic Toughbook, while older (32bit) it exceeds the system requirements. I'm doing a hard disk install, no dual boot.

    The first error during install was during the network mirror. It crashed and I was forced to disable the network card. Research shows that many say its due to network connectivity issues, but what I find interesting is I have zero internet issues when booting from Kali Live.

    So I skipped this part. I'll deal with it later. The next step of installation returned this error: "grub-pc package failed to install into /target/". So I read, and read. I found out that I could install GRUB later using the Live USB, so I had to skip this part.

    So after install, I restarted the computer. Booted Kali LIVE.

    Terminal--> Ran the script below, and of course, I get an error: "grub command not found"

    Code:
    mount /dev/sda1 /mntmount --bind /dev /mnt/dev
    mount --bind /dev/pts /mnt/dev/pts
    mount --bind /proc /mnt/proc
    mount --bind /sys /mnt/sys
    chroot /mnt
    grub-install /dev/sda
    update-grub
    exit
    umount /mnt/dev/pts
    umount /mnt/dev
    umount /mnt/proc
    umount /mnt/sys umount /mnt

    I'm out of ideas. fdisk shows 3 partions. SDA1, SDA3, SD5. KALI is on SDA1.


    Can anyone please, please assist.

    Many thanks,
    Rob

  2. #2
    Join Date
    2016-Dec
    Posts
    372
    You can always take the hard drive, put it in another system and do the installation there and finally put it back.

    Without any details on the crash and/or logs, there isn't much we can do. You don't even say where the installation crash.

Similar Threads

  1. Problems with WLAN and Grub installation
    By Crynetic85 in forum Installing Kali Linux
    Replies: 2
    Last Post: 2018-05-13, 06:10
  2. Wifi problems and grub problem
    By eduardo402001 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2017-05-08, 18:45
  3. noobbeenpwnslaped power hour oneplus pwnage
    By Noobbeenpwnslapt in forum Installing NetHunter
    Replies: 10
    Last Post: 2016-02-16, 21:33
  4. Problems with GRUB and windows 10
    By xndyb in forum Installing Archive
    Replies: 0
    Last Post: 2016-01-12, 23:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •