Results 1 to 5 of 5

Thread: Kali linux failed to get libpng12 (libpng12.so.0': No such file or directory) [on hold]

  1. #1
    Join Date
    2018-Dec
    Posts
    1

    Kali linux failed to get libpng12 (libpng12.so.0': No such file or directory) [on hold]

    Hello,
    I want to install gnome-screenshot but +I have some problems to install libpng12-0 on kali linux.
    Code:
    root@kali:/tmp# apt install gnome-screenshot
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
     libwebkitgtk-1.0-0 : Depends: libpng12-0 (>= 1.2.13-4) but it is not going to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    root@kali:/tmp# apt --fix-broken install
    The following additional packages will be installed:
      libpng12-0
    The following NEW packages will be installed:
      libpng12-0
    0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
    7 not fully installed or removed.
    Need to get 0 B/172 kB of archives.
    After this operation, 273 kB of additional disk space will be used.
    Do you want to continue? [Y/n] 
    (Reading database ... 413687 files and directories currently installed.)
    Preparing to unpack .../libpng12-0_1.2.50-2+b2_amd64.deb ...
    Unpacking libpng12-0:amd64 (1.2.50-2+b2) ...
    dpkg: error processing archive /var/cache/apt/archives/libpng12-0_1.2.50-2+b2_amd64.deb (--unpack):
     unable to install new version of '/usr/lib/x86_64-linux-gnu/libpng12.so.0': No such file or directory
    Errors were encountered while processing:
     /var/cache/apt/archives/libpng12-0_1.2.50-2+b2_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    I already check this link : https://stackoverflow.com/questions/...stalling-teens

    But it doesn't solve anything for me. Here is some information about my version:


    Linux kali 4.18.0-kali3-amd64 #1 SMP Debian 4.18.20-2kali2 (2018-11-30) x86_64 GNU/Linux


    any ideas ?


    Thanks a lot

  2. #2
    Join Date
    2016-Dec
    Posts
    594
    You probably did something wrong along the way, because it installs just fine. I suggest you reinstall Kali.

    By the way, using external packages or other repositories will break your system sooner or later.

    One last thing, make sure to update your system: apt update && apt dist-upgrade

  3. #3
    Join Date
    2019-Feb
    Posts
    1

    Post Install Winth another Versions

    Quote Originally Posted by awesomeman View Post
    Hello,
    I want to install gnome-screenshot but +I have some problems to install libpng12-0 on kali linux.
    Code:
    root@kali:/tmp# apt install gnome-screenshot
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
     libwebkitgtk-1.0-0 : Depends: libpng12-0 (>= 1.2.13-4) but it is not going to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    root@kali:/tmp# apt --fix-broken install
    The following additional packages will be installed:
      libpng12-0
    The following NEW packages will be installed:
      libpng12-0
    0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
    7 not fully installed or removed.
    Need to get 0 B/172 kB of archives.
    After this operation, 273 kB of additional disk space will be used.
    Do you want to continue? [Y/n] 
    (Reading database ... 413687 files and directories currently installed.)
    Preparing to unpack .../libpng12-0_1.2.50-2+b2_amd64.deb ...
    Unpacking libpng12-0:amd64 (1.2.50-2+b2) ...
    dpkg: error processing archive /var/cache/apt/archives/libpng12-0_1.2.50-2+b2_amd64.deb (--unpack):
     unable to install new version of '/usr/lib/x86_64-linux-gnu/libpng12.so.0': No such file or directory
    Errors were encountered while processing:
     /var/cache/apt/archives/libpng12-0_1.2.50-2+b2_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    I already check this link : https://stackoverflow.com/questions/...stalling-teens

    But it doesn't solve anything for me. Here is some information about my version:


    Linux kali 4.18.0-kali3-amd64 #1 SMP Debian 4.18.20-2kali2 (2018-11-30) x86_64 GNU/Linux


    any ideas ?


    Thanks a lot
    Screenshot from 2019-02-24 07-00-26.jpg
    I use 2018.4 and install libpng12 1.2.49
    downloaded from this link
    https://debian.pkgs.org/7/debian-mai...amd64.deb.html

  4. #4
    Join Date
    2019-May
    Posts
    1
    I am faceing same problem, also try all steps here and google search

    unable to install new version of '/usr/lib/x86_64-linux-gnu/libpng12.so.0': No such file or directory
    Errors were encountered while processing:
    /var/cache/apt/archives/libpng12-0_1.2.50-2+deb8u3_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@kali:~#

  5. #5
    Hi
    I have resolved this issue by upgrading my Kali Linux, hope it also works for you follow the below steps:-
    1: #gedit /etc/apt/sources.list
    2: paste this into your sources.list and save it
    deb http://http.kali.org/kali kali-rolling main non-free contrib
    deb-src http://http.kali.org/kali kali-rolling main contrib non-free
    3:#apt update && apt -y full-upgrade
    its take some time to upgrade your Kali Linux to its latest version

    Thanks

Similar Threads

  1. metasploit.service failed to load: No such file or directory!
    By XtremeLv in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-12-20, 21:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •