Results 1 to 2 of 2

Thread: [SOLVED] Unable to delete a directory by using rf or rfdir

  1. #1

    [SOLVED] Unable to delete a directory by using rf or rfdir

    I have recently installed Kali on Windows 10 via WSL. I already was using Kali Linux on Windows 10 on a Virtualbox. I transferred a folder named "Overthewire" into a USB drive from the Virtualbox Kali image. Then, through Windows, I pasted the folder into the Documents directory of the WSL Kali. Now, I am unable to delete the folder by using Windows since it says, "You need permission from the computer's administrator to make changes to this folder." But, I am the admin. I also went into the properties of the folder and went to Security to change the permissions, but it says, "You do not have permission to view or edit this object's permission settings."

    After this, I tried to delete the folder using the WSL Kali terminal. I was able to enter into the folder on WSL Kali, but there was no file stored in it, even though it had another folder when it was created in Virtualbox Kali (I used the ls -a command, but it still showed that no files were present in the folder). I used the du command on the drive and it shows me that 512 bytes of data is taken up by whatever's in the folder. I tried using rm -rf and rmdir, but to no avail. I have also tried <sudo chmod -R 777 Overthewire> and then tried sudo rm -rf and sudo rmdir, yet the folder still stays.

    What do I do to get rid of it?

    Update: The issue has been resolved.

    Capture3.jpg Capture2.jpg Capture.jpg
    Last edited by realhighdude; 2018-12-14 at 18:23. Reason: My issue has been resolved.

  2. #2
    Join Date
    How did you resolve it?

Similar Threads

  1. Delete Directory in Linux
    By lokeshjoshi in forum How-To Archive
    Replies: 2
    Last Post: 2022-08-03, 21:01
  2. Replies: 0
    Last Post: 2020-01-01, 00:14
  3. Unable to repair Grub2 - cannot find EFI Directory
    By cjlorenz81 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2017-05-31, 22:37

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts