Results 1 to 2 of 2

Thread: Kali linux with a custom TDE Trinity Desktop

  1. #1
    Join Date
    2013-Mar
    Location
    King Julian's Home
    Posts
    1

    Kali linux with a custom TDE Trinity Desktop

    Hi folks,

    I tried to have a custom iso that would really look like q4os but instead of just a "debian for n00bs", a fully functional and weaponized Kali. I created a specific variant as stated in the how-to and updated the sources.list. I wanted to have what q4os offers, so instead of building the DE from scratch, I pointed the mirror to q4os official mirror:
    Code:
    [root:/home/Projects/kali-live-build]# cat config/archives/tde-trinity.list.chroot                                                                                                                      (master✱) 
    deb http://q4os.org/q4repo/ q4os-1-0-cn main
    deb http://q4os.org/qtderepo/ jessie main
    deb http://ftp.debian.org/debian/ jessie non-free contrib main
    deb http://security.debian.org/ jessie/updates contrib non-free main
    deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free
    deb http://ftp.debian.org/debian/ jessie-backports main contrib non-free
    updated all the GPG keys
    Code:
    [root:/home/Projects/kali-live-build]# file  config/archives/tde-trinity.key.chroot                                                                                                                     (master✱) 
    config/archives/tde-trinity.key.chroot: PGP public key block Public-Key (old)
    [root:/home/Projects/kali-live-build]#                                                                                                                                                                  (master✱)
    then run the build script and got the following
    Code:
    The following packages have unmet dependencies:
     apt-listchanges : Depends: python3-debconf but it is not going to be installed
     bind9-host : Depends: libbind9-161 (= 1:9.11.5.P1+dfsg-1) but it is not going to be installed
                  Depends: libdns1104 (= 1:9.11.5.P1+dfsg-1) but it is not going to be installed
                  Depends: libisc1100 (= 1:9.11.5.P1+dfsg-1) but it is not going to be installed
                  Depends: libisccfg163 (= 1:9.11.5.P1+dfsg-1) but it is not going to be installed
     kali-desktop-live : Depends: cryptsetup but it is not going to be installed
     kali-linux : Depends: kali-desktop-common but it is not going to be installed
                  Depends: apache2 but it is not going to be installed
                  Depends: default-mysql-server but it is not going to be installed
                  Depends: haveged but it is not going to be installed
                  Depends: openssh-server but it is not going to be installed
                  Depends: openvpn but it is not going to be installed
                  Depends: samba but it is not going to be installed
                  Depends: snmpd but it is not going to be installed
                  Depends: sudo
     kali-linux-full : Depends: apache-users but it is not going to be installed
                       Depends: apktool but it is not going to be installed
                       Depends: armitage but it is not going to be installed
                       Depends: backdoor-factory but it is not going to be installed
                       Depends: bbqsql but it is not going to be installed
                       Depends: bdfproxy but it is not going to be installed
                       Depends: beef-xss but it is not going to be installed
                       Depends: bluelog but it is not going to be installed
                       Depends: bluesnarfer but it is not going to be installed
                       Depends: bluez but it is not going to be installed
                       Depends: burpsuite but it is not going to be installed
                       Depends: cewl but it is not going to be installed
                       Depends: cherrytree but it is not going to be installed
                       Depends: chirp but it is not going to be installed
                       Depends: chkrootkit but it is not going to be installed
                       Depends: cisco-torch but it is not going to be installed
                       Depends: clusterd but it is not going to be installed
                       Depends: commix but it is not going to be installed
                       Depends: cryptsetup but it is not going to be installed
                       Depends: cutycapt but it is not going to be installed
                       Depends: davtest but it is not going to be installed
                       Depends: deblaze but it is not going to be installed
                       Depends: dex2jar but it is not going to be installed
                       Depends: dirbuster but it is not going to be installed
                       Depends: dnmap but it is not going to be installed
                       Depends: dotdotpwn but it is not going to be installed
                       Depends: dradis but it is not going to be installed
                       Depends: dsniff but it is not going to be installed
                       Depends: edb-debugger but it is not going to be installed
                       Depends: enum4linux but it is not going to be installed
                       Depends: ettercap-graphical but it is not going to be installed
                       Depends: fern-wifi-cracker but it is not going to be installed
                       Depends: ftester but it is not going to be installed
                       Depends: ghost-phisher but it is not going to be installed
                       Depends: giskismet but it is not going to be installed
                       Depends: golismero but it is not going to be installed
                       Depends: gpp-decrypt but it is not going to be installed
                       Depends: grabber but it is not going to be installed
                       Depends: hexorbase but it is not going to be installed
                       Depends: hydra-gtk but it is not going to be installed
                       Depends: i2c-tools but it is not going to be installed
                       Depends: ifenslave but it is not going to be installed
                       Depends: inetsim but it is not going to be installed
                       Depends: iodine but it is not going to be installed
                       Depends: javasnoop but it is not going to be installed
                       Depends: jboss-autopwn but it is not going to be installed
                       Depends: joomscan but it is not going to be installed
                       Depends: jsql-injection but it is not going to be installed
                       Depends: king-phisher but it is not going to be installed
                       Depends: maltego but it is not going to be installed
                       Depends: maltego-teeth but it is not going to be installed
                       Depends: metasploit-framework but it is not going to be installed
                       Depends: mitmproxy but it is not going to be installed
                       Depends: msfpc but it is not going to be installed
                       Depends: netwag but it is not going to be installed
                       Depends: nikto but it is not going to be installed
                       Depends: ohrwurm but it is not going to be installed
                       Depends: ophcrack but it is not going to be installed
                       Depends: oscanner but it is not going to be installed
                       Depends: pack but it is not going to be installed
                       Depends: padbuster but it is not going to be installed
                       Depends: paros but it is not going to be installed
                       Depends: passing-the-hash but it is not going to be installed
                       Depends: patator but it is not going to be installed
                       Depends: pipal but it is not going to be installed
                       Depends: protos-sip but it is not going to be installed
                       Depends: proxystrike but it is not going to be installed
                       Depends: python-faraday but it is not going to be installed
                       Depends: python-rfidiot but it is not going to be installed
                       Depends: rake but it is not going to be installed
                       Depends: rsmangler but it is not going to be installed
                       Depends: sendemail but it is not going to be installed
                       Depends: set but it is not going to be installed
                       Depends: siparmyknife but it is not going to be installed
                       Depends: smali but it is not going to be installed
                       Depends: smtp-user-enum but it is not going to be installed
                       Depends: snmpcheck but it is not going to be installed
                       Depends: sparta but it is not going to be installed
                       Depends: spooftooph but it is not going to be installed
                       Depends: sqlitebrowser but it is not going to be installed
                       Depends: sqlninja but it is not going to be installed
                       Depends: sqlsus but it is not going to be installed
                       Depends: sslh but it is not going to be installed
                       Depends: stunnel4 but it is not going to be installed
                       Depends: suckless-tools but it is not going to be installed
                       Depends: thc-ssl-dos but it is not going to be installed
                       Depends: theharvester but it is not going to be installed
                       Depends: tlssled but it is not going to be installed
                       Depends: tnscmd10g but it is not going to be installed
                       Depends: twofi but it is not going to be installed
                       Depends: u3-pwn but it is not going to be installed
                       Depends: uniscan but it is not going to be installed
                       Depends: urlcrazy but it is not going to be installed
                       Depends: vim-gtk but it is not going to be installed
                       Depends: wapiti but it is not going to be installed
                       Depends: webscarab but it is not going to be installed
                       Depends: winexe but it is not going to be installed
                       Depends: whatweb but it is not going to be installed
                       Depends: wifi-honey but it is not going to be installed
                       Depends: wifitap but it is not going to be installed
                       Depends: wol-e but it is not going to be installed
                       Depends: wpscan but it is not going to be installed
                       Depends: zaproxy but it is not going to be installed
                       Depends: zenmap but it is not going to be installed
     linux-image-amd64 : Depends: linux-image-4.18.0-kali3-amd64 but it is not going to be installed
     live-boot : Depends: live-boot-initramfs-tools but it is not going to be installed or
                          live-boot-backend
                 Recommends: live-tools but it is not going to be installed
                 Recommends: rsync but it is not going to be installed
                 Recommends: uuid-runtime but it is not going to be installed
     perl-base : Breaks: perl-modules (< 5.28.1~)
     perl-modules-5.28 : Conflicts: perl-modules (< 5.22.0~)
     python : Depends: libpython-stdlib (= 2.7.15-3) but it is not going to be installed
              Depends: python2 (= 2.7.15-3) but it is not going to be installed
     python-reportbug : Depends: python-debianbts but it is not going to be installed
                        Depends: python-apt but it is not going to be installed
                        Depends: python-requests but it is not going to be installed
     python2.7 : Depends: libpython2.7-stdlib (= 2.7.15-5) but it is not going to be installed
     python3-reportbug : Depends: python3-debianbts (>= 1.13) but it is not going to be installed
                         Depends: python3-requests but it is not going to be installed
     reportbug-gtk : Depends: python3-gi-cairo but it is not going to be installed
                     Depends: python3-gtkspellcheck but it is not going to be installed
     tde-trinity : Depends: tde-core-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdeedu-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdegames-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdetoys-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdeaccessibility-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdeaddons-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdeadmin-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdeartwork-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdegraphics-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdemultimedia-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdenetwork-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdepim-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdeutils-trinity (>= 4:14.0.0~) but it is not going to be installed
                   Depends: tdewebdev-trinity (>= 4:14.0.0~) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    Just wondering if someone could give a hint on how to automatically fix the dependency issues during the build process.

    Thank you,

  2. #2
    Join Date
    2016-Dec
    Posts
    594
    Keep in mind that Kali uses Debian testing. Second thing: using other repos will mess up your kali sooner or later (and in this case it is sooner).

    The repos you've added are for the stable version of debian.

    In the end, you're better off compiling on Kali and possibly making your own packages.

Similar Threads

  1. Replies: 3
    Last Post: 2016-12-05, 23:54
  2. Replies: 2
    Last Post: 2015-12-26, 10:19
  3. Replies: 0
    Last Post: 2015-07-28, 19:17
  4. Suggestion for custom Desktop Environment
    By Corsov in forum Building Archive
    Replies: 3
    Last Post: 2015-05-05, 08:45
  5. Custom Kali ISO Desktop needs startx to load
    By staticn0de in forum Building Archive
    Replies: 0
    Last Post: 2014-09-21, 06:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •