Results 1 to 4 of 4

Thread: ssues updating to kernel 4.14.89 and realtek-rtl88xxau-dkms, using RPi3 B+ Kali

  1. #1
    Join Date
    2018-Sep
    Posts
    5

    ssues updating to kernel 4.14.89 and realtek-rtl88xxau-dkms, using RPi3 B+ Kali

    Hello, I?m trying to update the kernel to the latest as I?m having problems with my RTL8812AU adapter.
    I followed these commands:

    Code:
    sudo -Es
    cd /usr/local/src
    wget -O re4son-kernel_next.tar.xz https://re4son-kernel.com/download/re4son-kernel-next/
    tar -xJf re4son-kernel_next.tar.xz
    cd re4son-kernel_4.14*
    ./install.sh
    I got this result:

    Code:
    root@kali-pi:/usr/local/src/re4son-kernel_4.14.89-20181225# ./install.sh
    
        ++++ Install Re4son-Kernel? [Y/n] y
    
        **** Installing custom Re4son kernel with kali wifi injection patch and TFT support ****
    
        **** /boot is mounted ****
    
        **** Installing device tree overlays for various screens ****
        **** Checking for device-tree-compiler: install ok installed ****
    
        **** Device tree overlays installed                      ****
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Note, selecting 'kalipi-bootloader' instead of './kalipi-bootloader_4.14.89-20181225_armhf.deb'
    kalipi-bootloader is already the newest version (4.14.89-20181225).
    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Setting up realtek-rtl88xxau-dkms (5.2.20.2~20181106-0kali1) ...
    Removing old realtek-rtl88xxau-5.2.20.2~20181106 DKMS files...
    
    ------------------------------
    Deleting module version: 5.2.20.2~20181106
    completely from the DKMS tree.
    ------------------------------
    Done.
    Loading new realtek-rtl88xxau-5.2.20.2~20181106 DKMS files...
    It is likely that 4.14.62-Re4son-v7+ belongs to a chroot's host
    Building for 4.14.62-Re4son+ and 4.14.62-Re4son-v7+
    Building initial module for 4.14.62-Re4son+
    Error! Bad return status for module build on kernel: 4.14.62-Re4son+ (armv7l)
    Consult /var/lib/dkms/realtek-rtl88xxau/5.2.20.2~20181106/build/make.log for more information.
    dpkg: error processing package realtek-rtl88xxau-dkms (--configure):
     installed realtek-rtl88xxau-dkms package post-installation script subprocess returned error exit status 10
    Errors were encountered while processing:
     realtek-rtl88xxau-dkms
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Error completing: apt
    My kernel is:

    Code:
    root@kali-pi:~# uname -r
    4.14.62-Re4son-v7+
    Any help greatly appreciated

  2. #2
    Join Date
    2016-Dec
    Posts
    424
    The image already has reason kernel and all you got to do is install the rtl8812au driver. In this case, you probably want to reinstall the kali image, update (apt update && apt dist-upgrade) then reboot and finally install the rtl8812au driver: apt install realtek-rtl88xxau-dkms

  3. #3
    Join Date
    2018-Sep
    Posts
    5
    Yes thanks, I know I have the re4son kernel, I want to update to the ?newer? kernel as it automatically has support for my WiFi adapter. I ended up figuring it out, I uninstalled the Realtek driver and then ran the install for the kernel again and it ran without any errors.
    Last edited by Realpanda; 2 Weeks Ago at 03:35. Reason: Edit

  4. #4
    Join Date
    2016-Dec
    Posts
    424
    I meant the kali image already has the reason kernel.

Similar Threads

  1. Replies: 11
    Last Post: 1 Day Ago, 14:47
  2. Replies: 0
    Last Post: 2017-08-23, 14:39
  3. Replies: 1
    Last Post: 2017-05-12, 15:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •