Results 1 to 1 of 1

Thread: Does "InRelease is expired" indicate an upstream problem or am I doing something wrong?

  1. #1
    Join Date
    This is my first time trying to build a custom Kali image. I'm running Debian (9.6/stretch) and following the "Building Kali on Non-Kali Debian Based Systems" section of the docs. When I try to build the image the script seems to fail before the packages are downloaded. The error message is like this:

    E: InRelease file is expired since (Mon, 07 Jan 2019 00:00:00 -0600)
    This is different than the more common "expired key" messages I found while searching for a solution because it seems to be saying the file itself is expired, not the key. Is this a problem with something outside my machine or am I doing something wrong? How can I work-around or get more information about the problem?

    Update: when I run this today the expiration date does indeed increment, i.e.

    E: InRelease file is expired since (Tue, 08 Jan 2019 00:00:00 -0600)
    Also, I found that I can create a .mirror file to make the script use an alternate URL. If I run
    echo "" > .mirror
    and then run the build script again the error changes to this:
    E: Failed getting release file
    Last edited by maiki; 2019-01-08 at 14:47. Reason: Merge posts

Similar Threads

  1. Need advice on "Live" versus "Installed" custom builds
    By malakaldayook in forum Building Archive
    Replies: 3
    Last Post: 2017-10-03, 08:54
  2. Replies: 3
    Last Post: 2017-06-10, 09:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts