Dear all,
I recently booted Kali Linux 64 Bit on a USB. When I run it Live, however, I always have to wait five minutes and get the following error:

Failed to start LSB: thin initscript. See "systemctl status thin.service" for details.

After that I'm able to access Kali. When I run "systemctl status thin.service" in the terminal I get the following:

root@kali:~# systemctl status thin.service
● thin.service - LSB: thin initscript
Loaded: loaded (/etc/init.d/thin; generated)
Active: failed (Result: timeout) since Mon 2019-01-14 13:29:53 UTC; 2min 22s
Docs: man:systemd-sysv-generator(8)
Process: 1074 ExecStart=/etc/init.d/thin start (code=killed, signal=TERM)
Tasks: 0 (limit: 4504)
Memory: 10.4M
CGroup: /system.slice/thin.service

Jan 14 13:24:53 kali systemd[1]: Starting LSB: thin initscript...
Jan 14 13:29:53 kali systemd[1]: thin.service: Start operation timed out. Termin
Jan 14 13:29:53 kali systemd[1]: thin.service: Failed with result 'timeout'.
Jan 14 13:29:53 kali systemd[1]: Failed to start LSB: thin initscript.

I also tried the same procedure on three different PCs and all give me the same problem.
I also tried to change USB but it doesn't change anything.
I tried to boot Kali 32 Bit but it doesn't work as all the PCs I tried it are x64.
I also tried to boot Kali Linux x64 Light which works with no problems.
Not sure if it matters, but when I run Kali I don't have an internet connection.

I'm absolutely not an expert in Kali since I still have to start to study it, but I wanted at least have it running fine.

Can somebody explain me the problem and help me to solve it?

Thank you in advance.