Results 1 to 6 of 6

Thread: trouble booting into kali USB installer

  1. #1
    Join Date

    trouble booting into kali USB installer


    Recently downloaded latest Kali and win32diskimager, followed install instructions. Writing the img file was successful to a fat32 usb stick. I am unable to boot from the usb installer (sandisk32gb usb3 -tried running from the 2.0 ports as well). Since i wanted a persistent install with nvidia driver, my goal was to boot from the live usb installer, and gui install to another blank usb drive (same type), allowing kali to utilize my PC cpu and gpu for hardware acceleration. I tried selecting all the boot entries that show up, namely SanDisk, and it sends me to a weird EFI shell screen, and sits there. I type help and get a ton of commands - I dont know how to get to the kali installer and run the gui install to another usb. (also tried the macosx dd command for writing the kali dmg file... doesnt work either). Thanks for any help.

    My specs are 4770k cpu, 16g ram, gtx 1070, z87 board.

  2. #2
    Join Date
    What does that weird EFI shell screen look like? A screenshot would be helpful.

    Could you detail what you mean by unable to boot? Do you see the boot screen with kernel choices?

    In the meantime, one thing you can try is the latest weekly ISO. I'm not familiar with UEFI as much as I'd like and such but I know it works fine when you disable UEFI and enable Legacy BIOS.

  3. #3
    Join Date
    ok i managed to get the iso properly 'burned' to a live usb stick (16gb), i boot into it, select installer (target install drive is a 32gb usb stick).

    problem i run into is:

    trying guided partitioning for the 32gb stick (30.8 gb free space) outputs these parameters:
    SCSI9 (sdd)
    537 MB ESP B K (EFI system partition - boot flag enabled)
    13.4 GB ext4 / F (root mount point formatted in ext4)
    17.1 GB swap area (isnt this WAAY too big for a swap area?)
    1 MB free space (cannot remove)

    so I rather do manual partition because swap should be about 4 GB:
    SCSI9 (sdd)
    549 MB ESP B K
    26.0 GB ext4 / F
    4.2 GB swap area
    1 MB free space

    Install wizard continues without problems. Note: Did not ask to input user name or password (only a root password was requested). Did not ask to install GRUB boot loader (which from some searching is the problem im running into after installation - cannot load kali linux from my usb32 gb install in BIOS boot menu because apparently I have to manually install GRUB bootloader to my ESP partition created above. why cant kali linux 'know' that the ESP partition i created that has a boot flag enabled should be the target for the boot loader? makes no sense ). Why is this so complicated? My PC has had 3 different OS's in the past all running flawless. windows on ssd1, macos hackintosh on ssd2, and now i want kali linux on a USB 3.0 32gb stick - i realize there may be a complication since USB sticks arent standard install media (internal sata drives). but its all I can use. It appears the kali install tried to install an EFI grub loader into my macos SSD drive...really annoying! seems like it just picks a random internal drive to throw GRUB on, messing up my system internal drive - my mac os install is completely ruined now. nice. I know i didnt pick the wrong hard drive during formating! it just overwrit my macos internal SSD with a kali EFI partition- godamnit!

    I already have a kali live usb stick, but that doesnt allow for persistent storage nor nvidia drivers to make use of hardware acceleration - whats the point of live/persistent if you cannot utilize any drivers for system hardware?


    Was able to finally enter via BIOS boot menu selecting EUFI sandisk, was able to enter kali linux finally. From there ran:

    fdisk -l

    located the ESP partition of the kali usb stick and manually installed grub just to be sure:

    sudo grub-install /dev/sdd1 && sudo update-grub

    now after so much hassle i can boot my usb into installed kali. except for that this has been a complicated disaster. overwritten mac os internal drive, epic fail. i know I followed the instructions to a tee, even manually formatted everything properly, Im not a novice linux user, ive done this 5 times before. never with this many problems. please kali dev team fix these!. please dont let EFI / GRUB be randomly installed on internal drives because it OVERWRITES THE DRIVE rendering you OS and files GONE- allow a target partition to select for EFI / GRUB. fix the guided partitioning (17 GB of swap on a 30 GB usb stick makes no sense). add a normal user account setup n addition to root user during install. write better instructions, for a user friendly experience. off to reinstall mac os, thanks kali !

  4. #4
    Join Date

    Foul language

    oh my god it messed up my windows boot too, HOW DO i get rid if grub this is a NIGHTMARE!!!!! its affected both windows and mac normal boot up, when I never even targeted those drives during kali install. my kali usb sticks arent even attaached to the system yet im getting stuck at grub rescue> screen and mac os drive that cannot boot. please how do i remove GRUB EFI from both hard drives.
    Last edited by maiki; 2019-01-16 at 10:17.

  5. #5
    Join Date
    Ok i deleted grub from its wrong place on ssd. I am trying a reinstall onto a USB stick, I unplugged all internal drives so that it's impossible to screw them up with a Linux boot loader.

    Can someone please explain to me why the install is so hard even now? I'm getting problems like cannot create file system during manual partition of the 32 GB USB stick, where I created a root partition of 26.5 GB ext4 and a swap area of 4.3 GB. Why does the guided partition create a root mount partition of 13 GB and a swap area of 17 GB? It just doesn't make sense why it would need so much swap. Both manual or guided partition and install result in this error:

    "failed to Create file system
    The ext4 file system creation in partition number one of SCSI9 (0,0,0) (sda) failed.

    My system has 16 gigs of RAM already. I swear installing this is a nightmare. I wish the writers of the kali installation guide would elaborate on how to manually partition a hard drive or USB stick properly and also How to get the external portable installation to boot consistently without problems

  6. #6
    Join Date
    Had an install finish properly. I rebooted seleted usb SanDisk and saw kali splash screen. It then tries to load into kali and i get a shell screen error:
    Gave up waiting for root file system device. Common problems:
    -boot args (cat /proc/cmdline)
    - check rootdelay (Did the system wait long enough?)
    -missing modules (cat proc/modules; ls /dev)
    ALERT /dev/sdb1 does not exist. Dropping to a shell!

    BusyBox v1.27.2 (debian 1:1.27.2-3) built in shell(ash) enter help for a list of commands.

    Ok upon ls /dev command it shows only sda volume showing, but its trying to boot from sdb (after I removed the live usb the newly installed usb became sda). So it seems i need to point the bootloader to choose sda as root device. How?

    Update: figured out how to edit grub root entry, to point to proper device. All good incan boot fine now. My remaining question is still: how can I manually partition the entire USB stick so that the swap file is only around 4 GB so I can actually utilize most of my disk space? Why does the guided partitioning make a 17 GB swap file on a 30gb usb stick? I dont get it.
    Last edited by kingfitz; 2019-01-20 at 04:16.

Similar Threads

  1. Replies: 4
    Last Post: 2017-08-24, 16:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts