Results 1 to 11 of 11

Thread: Mount CD ROM Problem In ISO Mode and Boot flag Won't Turn ON in DD Mode !!

  1. #1
    Join Date
    2019-Jan
    Posts
    22

    Post Mount CD ROM Problem In ISO Mode and Boot flag Won't Turn ON in DD Mode !!

    hey guys i got stuck into an error i.e "Can't mount and detect CD-ROM drives".
    i'm not able to bypass this error. i'm using Dell Inspiron 7567 gaming Laptop , which do not include CD/DVD RW as Hardware i.e There is no way to insert CD/DVD .
    also i'm using "kali-linux-2018.4-amd64" GNOME. i picked up rufus(latest version too) to make bootable usb , after which i successfully select UEFI Boot mode and then i got stuck in this error.
    i tried to mount bootable usb into cd rom but after mounting no outcome.it seems to be trapped @ mount cd rom loop.
    i tried every possible solution from google/youtube but still no outcome.
    once i tried DD instead of ISO boot .....after selecting DD i successfully bypass this error.but during assigning partitions i won't able to turn boot flag on and in this case kali installation failed.

    in both the cases i'm unable to boot kali on my machine.

    what should i do to bypass this error on my machine "Can't Mount and detect CD-ROM" or how can i turn boot flag on???
    is this some kind of bug or what??


    Note: i already tried every possible solution available on internet.
    1) Mounting
    example: mount -t vfat /dev/sdc1 /cdrom

    2) Taking Out USB and Re-insert.

    3) Legacy Boot

    4) DD Mode(It Won't Turn Boot flag On)

    5) running cat /dev/sdc1
    Last edited by alexertech; 2019-01-25 at 20:50.

  2. #2
    Join Date
    2019-Jan
    Posts
    2
    I'm like this too

  3. #3
    Join Date
    2019-Jan
    Posts
    22
    Do you stuck into this??

  4. #4
    Join Date
    2016-Dec
    Posts
    554
    Where does that CD-ROM issue appear? A screenshot in this case would be helpful.

    It's weird, I tested Kali in the past on a similar laptop (7xxx series) and it booted just fine without UEFI and BIOS in Legacy mode.

    The command you mention aren't useful:
    1-2. You're just connecting it, like you would plug it on a Windows machine. It doesn't do anything.
    3. Legacy boot works fine, you just got to get to the boot menu and select the right USB
    4. Should work
    5. Doesn't do anything

    Fdisk would be the way to add the bootable flag on the partition

    Try using Win32disk imager like mentioned in the docs: https://docs.kali.org/downloading/ka...ve-usb-install

  5. #5
    Join Date
    2019-Jan
    Posts
    22
    Hello sir....thanks for your time!!! I'll tell you in brief
    I select uefi boot mode
    In case of iso burn ...the CD ROM issue appears after language selection that is during mounting CD ROM process (in iso mode this error "can't mount and detect CD ROM drives" won't bypass i hope it will not a hardware issue ) which is an initial part of installation.

    Secondly in case of dd mode I boot in same uefi mode
    CD ROM error successfully got bypass but later during assigning partitons i tried to on bootable flag but it won't turn on... although installation completed successfully but after all this process Kali won't start normally .
    Yeah it asks for user name and password but after that no response...that is whole black screen.
    I tried to restart machine again but this time only windows boot up.

    P.S: I tried windiskmanager32 but it won't open up Kali installation section , causing some booting issues , that's why I choose rufus.
    Also I didn't get a choice to select between windows and Linux
    After installation When machine restarted it automatically open up Kali menu

    I'll post screenshot as soon as possible.

    Thanks

  6. #6
    Join Date
    2016-Dec
    Posts
    554
    Where does the mounting happens? Is it before it reaches grub? Is it after? Is it in the installer?

  7. #7
    Join Date
    2019-Jan
    Posts
    22
    Mounting happens at initial process !!!yes, it occurs before reaching grub !!!no, not in the installer Screenshot_20190202-021408.jpg

  8. #8
    Join Date
    2016-Dec
    Posts
    554
    No, it is during the installer. You've already reached grub. Looking at the screenshot, it doesn't really look like an issue, as it is detecting hardware. Could you show the screenshot that has an error, where something fails.

  9. #9
    Join Date
    2019-Jan
    Posts
    22
    Hello sir ....thanks for your time, it means a lot!!!
    Somehow I managed to install Kali on my machine ...but still causing some problems in giving flow to it .
    I boot USB using windisk32 ..this time it worked and I successfully boot into uefi mode and bypass the CD ROM error. But still bootable flag issue won't solve out .
    I installed Kali successfully without a single issue.
    Then after Machine restarts ...Kali loads , asks for username and password but after entering login credentials the screen somehow freezes ...it shows greyish blank screen( same screen color which appears during asking for login credentials) without mouse pointer . I waited for about 30 to 40 minutes with a hope that something solved out but still no outcome.

    Is this a problem of bootable flag ??? Or problem of Nvidia graphic card(my machine has gtx 1050 ti) or any other problem???
    What should I do .... shall i go for command line mode or recovery mode???
    One more thing : when I load windows the partiton in which I install Kali, doesn't open ...it asks for format.
    How can I assign boot flag using fdisk ...???

  10. #10
    Join Date
    2019-Jan
    Posts
    22

  11. #11
    Join Date
    2016-Jan
    Posts
    12
    People run into many issues for dual booting kali. Its because at the end of kai installer it tries to install grub boot loader on what it thinks is the proper system drive. Then when you boot, grub takes precedence over other OS. Thats why i recommend install kali onto external usb(unplug all drives except kali usb installer and target drive) or just use live Usb stick which can plug and play on any system. Also if you remove disks or usbs with a kali disk install on them you may get missing device error after grub screen tries to load kali. In this case press e at grub/kali screen and edit the root device path to match your devices id. Google the issue others have had it.

Similar Threads

  1. Problem with graphical install in UEFI mode for dual boot
    By Anaesthesia in forum Installing Archive
    Replies: 8
    Last Post: 2018-08-15, 11:55
  2. How to turn off the beep sound after boot in UEFI mode?
    By Conder in forum General Archive
    Replies: 0
    Last Post: 2017-09-29, 17:39
  3. Replies: 1
    Last Post: 2015-10-21, 02:22
  4. Do I need to turn off usb debug mode after install nethunter
    By iroy2000 in forum NetHunter General Questions
    Replies: 1
    Last Post: 2014-09-28, 06:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •