Results 1 to 5 of 5

Thread: Nethunter on OnePlus One - several odd things I cannot find answers to on forum or in Google

  1. #1

    Nethunter on OnePlus One - several odd things I cannot find answers to on forum or in Google

    Hi everyone. I always spend at least 2 days looking for log entries or similar threads or something that can give me a hint on how to get started but I'm completely at a loss currently. Hopefully someone smarter than myself can help me out.

    Quick details;
    Oneplus One with Lineage 15.1 + addonSU
    Latest BusyBox installed from Play Store
    Latest nh-term & nethunter APKs from here:
    Newest kalifs-armhf-full.xz from here:

    Once base system was installed I copied over top (thank you to whoever created that).

    Now the oddnesses

    1 - The first time I ran an HID attack it worked perfectly, three times. I moved on to an nmap scan of the AP and the phone crashed. Now the HID devices do not show up automatically. I have to manually do a setprop sys.usb.config hid from the androidsu (it doesn't work from kali chroot).

    1.1 - If I try to enable the HID devices while the USB is plugged in the phone crashes. If I enable them and then plug the USB in the phone crashes.

    2 - As previously stated, trying to do an nmap crashes the phone. Everytime. I've tried doing on over SSH so I have some details after it crashes, but even at debug level 9 all I get is that it's resolved the host and is starting the scan.

    3- The Nethunter app goes through its startup process, but doesn't seem to be able to actually start any service on-boot.

    Since the phone crashes everytime I have no logs to look at. I've tried wiping it clean and doing everything again and have the same issues. If anyone can give me an idea where to start looking it would be most appreciated.

  2. #2
    Join Date
    Hi novicehacker,

    You can try the latest test release of the nethunter app:

    That's been updated for Oreo and Pie
    - - - - - - - - - - - - - - - - - - - - - -
    Check out "Sticky Fingers Kali-Pi":

    Now with mana-toolkit and more goodies!

  3. #3
    Thank you re4son. Your advise has helped me out many times, I'm not sure how I missed those updates.

    After some more trials I've found the HID issues are basically fixed. A cold boot results in the HIDs missing, while a reboot seems to let them auto detect.

    It still can't seem to start services on-boot. I can fix that with a cron job if that starts at boot.

    The bigger issues is nmap still crashes the phone entirely. I should be able to do that with the internal wireless correct? Fing works. cSploit core install also crashes the phone.

    Any ideas?

  4. #4
    Join Date
    You are probably just missing a couple of recent updates that are important for oreo.
    The best thing would be to build a new image. I've asked Phreya if he could add his kernel to the nethunter-devices repo so you can easily build it yourself. I'm sure it's his kernel that you are using.
    Let's wait for his response. I think I've tracked down his github repo and I'll ping him there as well to speed things up. Fingers crossed.
    - - - - - - - - - - - - - - - - - - - - - -
    Check out "Sticky Fingers Kali-Pi":

    Now with mana-toolkit and more goodies!

  5. #5
    Thanks for the reply Re4son. Not sure why I didn't get the alert that time.

    I honestly have no idea how to do that, but I'm sure with some digging I could figure it out.

    That makes sense. Since Fing works in Android and I see nothing different between the nethunter nmap and nmap on Kali Pi I'm inclined to think it's a chroot / kernel issue.

Similar Threads

  1. NetHunter 3.1.0 on OnePlus One
    By BeNe in forum Installing NetHunter
    Replies: 3
    Last Post: 2016-07-25, 01:33
  2. Replies: 11
    Last Post: 2016-07-22, 12:17
  3. OnePlus One Nethunter 3.0
    By brsgdc in forum Installing NetHunter
    Replies: 23
    Last Post: 2016-05-04, 20:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts