Results 1 to 7 of 7

Thread: UVC control error on clean boot 2018.4

  1. #1
    Join Date
    2017-Mar
    Posts
    14

    UVC control error on clean boot 2018.4

    Hey all. I typically spend a few months with a Linux distro then switch. I've been a sysadmin for 11 years and have decided to pursue a new career in either software/web development or InfoSec (pentesting). That being said, I'm running a Lenovo X1 Carbon Gen4 and have never had issues installing any Linux distros before, Kali included. I just tried installing both the rolling 2018.4 and the weekly build. Both gave the following errors upon clean boot: uvcvideo: Failed to query (GET_INFO) UVC control 15 on unit 1: -32 (exp. 1). I'm not familiar enough diagnosing these more advanced Linux boot issues but I'm guessing it's something firmware related with one of the laptop components? Any help would be appreciated. Upon further investigation I found some threads (not on this forum) saying that UVC involves the webcam, so that's odd. Anyway, again, help would be greatly appreciated so I can get Kali back up and running stable! Thanks.

    - Sully
    Last edited by Bsullivan1983; 2019-02-01 at 20:55.

  2. #2
    Join Date
    2016-Dec
    Posts
    554
    Does it go to the graphical login prompt or is it stuck at boot?

  3. #3
    Join Date
    2017-Mar
    Posts
    14
    Quote Originally Posted by Mister_X View Post
    Does it go to the graphical login prompt or is it stuck at boot?
    I'll get the grub loader/gui login prompt but once I choose to boot into Kali it throws that UVC message at me and I have to restart.

  4. #4
    Join Date
    2017-Mar
    Posts
    14
    I really can't find much info about this regarding specific issues. It's a Linux USB Video Class (UVC) driver which defines video streaming functionality on the Universal Serial Bus. Seems like something Kali should have working "out of the box." I've had no issues up until 2018.4.

  5. #5
    Join Date
    2017-Mar
    Posts
    14
    Just reinstalled Linux Mint with no issues. It must be something with the 2018.4 kernel and a piece of hardware in my laptop. Hmm.....

  6. #6
    Join Date
    2016-Dec
    Posts
    554
    So, it gets stuck at boot with the error message?

    Try the weekly iso to see if it's better, it has a more recent kernel: http://cdimage.kali.org/kali-weekly/

  7. #7
    Join Date
    2017-Mar
    Posts
    14
    Forgot to update the thread: I fixed the issue. At first, I thought it was something to do with an update to Kali's kernel and something to do with the webcam. I went into the BIOS and disabled the webcam/microphone, rebooted, got the same error. Then, I got the idea to change from booting UEFI only (which has ALWAYS worked in the past) to running both, choosing UEFI to run first. Boom, problem solved. I'm getting some keyboard input lag at the Kali/OS selection screen but other than that everything is working great. I'm not sure if Lenovo did something in a BIOS update since I was last running 2018.2, or if Kali did something with their kernel, but problem solved. I just REALLY wish I could find what that "error" message actually means. Literally can't find any information about it anywhere. Found similar things, but nothing that compared exactly to what I have.

Similar Threads

  1. Failed to load regulatory.db error after clean installation
    By Obtice in forum Kali Linux TroubleShooting
    Replies: 2
    Last Post: 2018-09-24, 11:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •