I've been trying around for at least 4 hours today to get a dual boot with Kali and Win10 working, but I just can't get it to work.

So normally, on the computer, there's Windows 10 instsalled. In the computer, there are 2 drives, 1 x 500GB and 1 x 1000GB. On the 500GB drive, there's Windows installed, that's why I decided to split the 1000GB drive and unallocate 200GB of that for Kali.

After doing so, I made a bootable USB Stick with Kali on it, using Rufus. First, I used the wrong option, now I used DD to write the data on the USB Stick.

Next, I tried installing Kali on the unallocated 200GB. Therefore, I booted from the USB stick, selected Installation, clicked through the points and when it came to the drive to install on I chose manual, picked the 200GB and chose to automatically create partitions and put everything on one (suggested for beginners).
Installation then went through and then, the problems came up.

1. problem: When Kali booted after installing, I could enter the username and password, set while installing and after that, I ran into an empty screen. This screen had the same background as while logging in, so it's not completely black, but grey with a bit of a pattern. The problem: This screen remained, propably it's a error in displaying, but no matter if I moved the mouse to the left or to the right, there was nothing to see at all.

Besides that I have the 2nd, propably bigger problem: After I booted into Windows and then tried to boot back to Kali, it's not even getting to login any more. I can first pick Kali or Windows in GRUB, when I pick Windows, it's working fine, but when I pick Kali, I get stuck in the initramfs screen, where it says "No init found. Try passing init=bootarg".... I searched for this problem a lot, but couldn't really find a problem causing it.. I tried disabling fast boot in windows, no result, I searched for something with ext4 in Windows, didn't find anything... I have really no idea, what the problem is, but propably Windows changes something on the partitions of Kali after starting it.

Are there any ideas in order to fix my problem?

Thanks in advance!