Results 1 to 4 of 4

Thread: kali 2018.4 pi 3b+ networking fails

  1. #1
    Join Date
    2019-Jan
    Posts
    3

    kali 2018.4 pi 3b+ networking fails

    Running Kali 2018.4 on a Raspberry Pi 3B+ using a 32 Gb SD chip. I'm able to login & change password. Create new accounts & setup a user account settings. But when I connect Ethernet or WiFi to my router that all other machines have no issues connecting to internet, fails with this configuration. Here's the thing. This pi came as a Retropie kit that is fully functional with internet over Ethernet or WiFi. I'm able to use this configuration for now, but I really wanted to use it as my testing platform with straight Kali.

    Updates can't work due to this issue.

    Further complicating things, all the normal controls I'm used to have changed. I guess. Ping doesn't work, or ifconfig, iwconfig & the lot are old school from what I'm reading online.

    I've tried Re4son & it wouldn't load at all. I was so happy to see Kali 2018.4 boot to a desktop environment, only to see those feelings fall by the wayside when I couldn't even do an uodate after setting up the use account.

  2. #2
    Join Date
    2016-Dec
    Posts
    616
    Try 2019.1. It has re4son stuff in there.

    Obviously, if you don't have any network connection, ping won't work. ifconfig, iwconfig still work (partially for iwconfig depending on your card).

  3. #3
    Join Date
    2019-Jan
    Posts
    3
    K. I'll try 2019.1 & see if it flies. Yeah I thought it should be at bare minimum a grandfathered in commands. Maybe it's just a bad download or something. The key matched verification. Anyway, I'll let you know how it goes.

  4. #4
    Join Date
    2019-Jan
    Posts
    3
    So I tried 2019.1 with the same scetchy results.

    Browser fails to fully load.
    I can ping to Verizon's 4.2.2.2 !
    I install tightvncserver & I don't find it in /etc/ - it

    I can go back to raspian that came with it but the functionality is in extreme lockdown do to the retropi config. When I use that os vnc, internet, ssh, rdp, ftp all work fine.

Similar Threads

  1. Replies: 10
    Last Post: 2018-11-20, 21:34
  2. [2018.4/KDE] Login screen fails to launch GUI. Stuck in text mode
    By ASGR in forum Kali Linux TroubleShooting
    Replies: 3
    Last Post: 2018-11-12, 14:31
  3. GRUB2 (sdb /sdb1) Fails.. AMD fails.. Airodump-bugs..
    By silencio in forum Installing Archive
    Replies: 1
    Last Post: 2014-04-29, 15:54

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •