Results 1 to 2 of 2

Thread: Issues installing Kali 2019.1 on MSI Laptop

  1. #1
    Join Date
    2019-Feb
    Posts
    1

    Angry Issues installing Kali 2019.1 on MSI Laptop

    Hello! How are you all doing?
    This is my very first post (and very first attempt to install any distro of Linux) on these forums, so I will blast all of you with a lot of questions.
    I bought an MSI GV62 7rd Gaming notebook (specs will be defined later on this post) which I used for gaming on Windows. But now I've started a course to get the CEH and CISSP certifications which, obviously, require me to practice at home.
    I was using VMWare and VB to boot Kali, but it didnt work well (it worked, but not as I wanted, and resolution was horrible and I couldn't fix it).
    So I had this idea of installing it on my laptop (by using DUAL BOOT with WIN 10). This is where the troubles began.

    MSI Notebook Specs:
    - WD SSD 256gb Green
    - HDD Seagate 1tb
    - Intel i5 6400hq (non OCed, never OCed)
    - 8gb RAM (generic)
    - Nvidia GeForce GTX 1050 (4gb version)
    - BIOS was updated to it's latest official tested firmware.
    - BIOS boot modes= Legacy, UEFI, UEFI with CSM (tryied all of them, secure boot is DISABLED)


    I booted up a Live Kali DVD from a USB stick (in legacy BIOS mode) and then the GRUB showed up with the classic options (Normal, Failsafe, Forensic, Install, Graphical Install). When I select live, it won't boot: It's stuck at "A Start job is running on live-config bla bla bla 18min 36s/no limit" and then it stops counting time and the only option here is hard resetting.
    I tryied this like 2 or 3 times with no success, so I decided to boot in FailSafe Mode, which seemed to work.
    Once FailSafe mode booted, I used gParted to partition the SSD into a 120gb volume for Windows and another (150gb) for Kali. And just after this I rebooted to Graphical Install Mode, everything went fine, partition worked, installer worked and finished. So I rebooted to start using my new Kali Linux OS but whoooops: after I put my password and try to log in the screen goes all black and nothing happens: the machine crashes and nothing is left to do but hard resetting (again).
    After like 50 attempts and three days of "not-doing-anything-but-make-this-OS-work" I am starting to think crazy things like throwing the laptop through the window and give up (jk).
    So, everything I did I could roll back to it's original state, until now.
    (I forgot to say, Windows still works properly).
    When I was tired of trying to install it on my SSD, I tryied on the HDD, which ended up in the same black screen and hardresetting issue, but this time I have 3 partitions on my HDD which there's 1 (the EFI) that cannot be deleted through DiskPartition nor DiskMgMt on Win, so I tryied to boot the Win Installer to raw format it, but the Installer for Windows 10 wont work now.
    So I tryied once more with fail-safe mode, but this time it won't boot neither. It's totally broken.
    I'm seriously concerned about the health of my HDD (I know, as an IT that there's always a way to roll it back to it's original state, but I don't know how xD)
    So now I have two issues: A bad partitioned Hard Disk Drive. And a not installed Kali Linux.

    Please help me, I'm desperate.

  2. #2
    Join Date
    2016-Dec
    Posts
    806
    If live doesn't work, you may want to stick to a VM.

    Before doing any change that you're unsure about to a HDD, you can always use clonezilla to back it up on another drive.

Similar Threads

  1. 2 old laptop screen issues
    By shaberu in forum Installing Archive
    Replies: 1
    Last Post: 2013-07-27, 21:20

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •