Results 1 to 5 of 5

Thread: Kali-4.19x64 - Ati HD 4670 ( fglrx-legacy-driver )

  1. #1
    Join Date
    2019-Feb
    Posts
    1

    Kali-4.19x64 - Ati HD 4670 ( fglrx-legacy-driver )

    Hello Network Guru's and Proffesional, my name is Martin and i just installed this awesome operation system on my home pc.
    As i expected i run in some troubles, but the main one that i can't fix myself is the GPU.

    I have ATI HD 4670 (Pci-e ddr3 512mb) video card in the Pc just for some media features like streaming, some level of gaming and videos.
    I like to use it for gaming wish Steam: CS 1.6 , CS:GO , JKA, but without drivers is not possible.

    Version of Linux 4.19.0-kali3-amd64 #1 SMP Debian 4.19.20-1kali1 (2019-02-14) x86_64 GNU/Linux

    As this page https://wiki.debian.org/ATIProprieta...st_Legacy_13.1 tells me the correct driver is 13.1 ( aka fglrx-legacy-driver )
    So i did added bellow repo to my sources.list and apt-get update the distro.
    -------------------- deb http://httpredir.debian.org/debian/ wheezy-backports main contrib non-free
    But then i try to install the fglrx and i got this log in my console.
    Code:
    root@home:/etc/apt# apt-get install fglrx-legacy-driver
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     fglrx-legacy-driver : Depends: xorg-video-abi-12 but it is not installable or
                                    xorg-video-abi-11 but it is not installable or
                                    xorg-video-abi-10 but it is not installable or
                                    xorg-video-abi-8 but it is not installable or
                                    xorg-video-abi-6.0 but it is not installable
                           Depends: glx-alternative-fglrx (>= 0.3)
                           Recommends: fglrx-legacy-modules-dkms (= 8.97.100.7-3~bpo70+1) but it is not going to be installed or
                                       fglrx-kernel-8.97.100.7
                           Recommends: libgl1-fglrx-legacy-glx (= 8.97.100.7-3~bpo70+1) but it is not going to be installed
                           Recommends: libgl1-fglrx-legacy-glx-i386 but it is not installable
                           Recommends: fglrx-legacy-atieventsd but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    What is the correct way to use this feature? , Can you please point me in the right direction
    Thank you in advace. Have a nice evening

  2. #2
    Join Date
    2016-Dec
    Posts
    594
    You should remove the repo, it will mess up your kali install. Good luck on finding a driver.

  3. #3
    Join Date
    2016-Dec
    Location
    Canada
    Posts
    270
    For one thing it is possible, to add additional repos. But thats if you can get it working. ( or maybe if the repo is active?) I tried but good luck.

    https://www.kali.org/tutorials/advanced-package-management-in-kali-linux

    (Ps just copy paste link i gues$)

  4. #4
    Join Date
    2016-Dec
    Posts
    594
    I never said it was not possible. It is just strongly advised against doing it.

  5. #5
    Join Date
    2013-Apr
    Posts
    167
    please don't try , it may crash your kali , mine is similar with yours . my GPU is RX480 .
    hashcat ,can't show my GPU . openoffice Opencl can't be use . i am waiting for
    kali team to solve the problem.

Similar Threads

  1. Replies: 10
    Last Post: 2018-01-03, 08:46
  2. Is it possible to enable KMS with fglrx ATI driver on Kali?
    By SeM in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2014-10-25, 22:10
  3. AMD Catalyst Mobility Radeon HD 4670 driver
    By piermark in forum TroubleShooting Archive
    Replies: 39
    Last Post: 2014-03-14, 20:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •