Results 1 to 5 of 5

Thread: Need Help with the Installation of Kali Linux on my Dell XPS 8900

  1. #1
    Join Date

    Need Help with the Installation of Kali Linux on my Dell XPS 8900

    Hello All,
    I Have a Dell XPS 8900
    Intel(R) Core i7(TM)-6700
    Nvidia GeForce GT 730

    I'm trying to install kali linux in dual boot with windows 10 (already install in my computer). I first figured out some errors at the begining of the installation due to UEFI boot. And now installation process is completed, but when trying to boot up thats the problem really start and I got some errors and when looking at dmesg I can
    "Bluetooth hci0: failed to load" and
    "tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080 f80"

    On Grub menu I pressed "e" and on linux line I add "pcie_aspm=off nouveau.modeset=0"
    but for those two above errors I opened a terminal, I created a file blacklist.conf in /etc/apt/ and blacklist btusb and tpm_crb and then rebooted again.
    And I also ran command "dhclient eth0" to allow my computer to be connected to internet, then performed the following command in order to update some packages.
    I update the souce.list file according to recommendations of the official web site the run "apt-get update" apt-get Upgrade and apt dist-upgrade.
    After I rebooted, but from now the when rebooting Kali does not start at all and stay stuck with message "Started update UTMP about System Runlevel changes".
    I first tried "apt-get -f install" and rebooted again but same problem.
    Secondly, I tried "apt-get autoremove gnome-core gnome-shell gnome-session" and "apt-get autoremove gnome-core gnome-shell gnome-session", then rebooted but same problem.
    And when searching again on Internet, It seems like this is due to Nvidia card. And when checking file /var/log/ for some errors, I could see below suspected messages:

    (EE): Failed to load module "nv" (module does not exist, 0)
    (EE) [drm] Failed to open DRM device for pci:0000:01:00.0:-19
    (EE) open /dev/dri/card0: No such file or directory

    And I also checked the status by running command: systemctl status systemd-update-utmp-runlevel.service
    here is a part of the output:
    Loaded; loaded (/lib/systemd/systemd-update-utmp-runlevel.service; static; vendor preset: disabled)
    Active: Inactive (dead)
    process: 9801 ExecStart=/lib/systemd/systemd-update-utmp runlevel (code=exited, status=0/success)

    And when searching on internet nothing very clear, and I have no more ideas about this current issue

    So please, can you help me to better understand and to fix this issue.

    Best Regards.

  2. #2
    Join Date
    it does DHCP by default, no need to do that. You may want to blacklist nouveau as well, so you don't need the modeset for nouveau.

    There is no need to update the sources.list either.

    The only reason to run apt-get -f install is when there is a package conflict and that means your repos are probably messed up.

    If you aren't using 2019.1, use it to reinstall your system.

  3. #3
    Join Date
    Thanks Mister_X for your answer,

    Sorry I didn't mentionned the version I used. I was using kali-linux-2018.3a-amd64 for the installation.

    Okay, I will try with the 2019.1 version as suggested and revert back.

    Thanks for your availability and your good understanding.

    Best Regards.

  4. #4
    Join Date

    I have tried to reinstall with 2019.1 as suggested with the same procedure, I mean I blacklisted "btusb" and "tpm_crb" modules, and also replaced "quiet" with "pcie_aspm=off" at linux line of GRUB, but it is the same problem and issue still present.
    Screen stucks with message "Started update UTMP about System Runlevel changes".

    I accessed a terminal (ALT+F2) and went through Xorg.log if I could get some indications or informations and I found the same errors like before (see below link to the screenshot ).

    And I'm also and still making research at my side in order to try to fix the issue.

    Thanks for your availability and good understanding.

    Best regards.

  5. #5
    Join Date

    Hello All,

    To informed you that I finally succeed to dual boot Kali and Windows 10 on my Dell XPS 8900.

    Here are the steps I followed for my case:

    1. I used Kali 2019.1 and boot from a DVD on UEFI mode
    At GRUB boot option I went to option "Graphical Install". I press "e" to enter edit mode.
    I got to the line that starts "linux". At the end of the line I added "pcie_aspm=off" then pressed F10 to boot again from medium.

    2. The system went through the installation.
    At step Network configuration, when asked to choose the interface: this time I selected "wlan0 interface" instead of "eth0 interface" (before I was selecting eth0). It is true that I'm connected through both interfaces.
    The installation completed and the machine rebooted.

    3. The machine reboots via the newly-installed grub boot loader.
    At default entry Kali linux I press "e" again to edit the "linux" line by replacing the "quiet" with "pcie_aspm=off" and F10 to boot.

    4. After the system started, I made the previous change to be persistent.
    In a terminal, I edit the file "/etc/default/grub" as follow and saved it.
    At line GRUB_CMDLINE_LINUX_DEFAULT="quiet", I replaced "quiet" with "pcie_aspm=off". Now the updated line is GRUB_CMDLINE_LINUX_DEFAULT="pcie_aspm=off"
    I just tried to make sure that this line GRUB_CMDLINE_LINUX_DEFAULT="pcie_aspm=off" is present.

    After editing the the grub file, as root I issued command "update-grub".

    5. I restarted to test again, and Kali started normally.

    BUT there are just one or two below errors that I found in "dmesg" and that I would like to fix.

    error1: (bluetooth is currently not working)
    Bluetooth hci0: Firmware; failed to load rtl_bt/rtl8723b_config.bin

    tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080 f80
    tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080 f80

    For error1, when looking in directory /usr/lib/firmware/rtl_bt/ the file rtl8723b_config.bin was missing.
    I tried to download it in that directory using this link :
    I restarted the machine but I still have belows errors link to bluetooth:
    Bluetooth: hci0: command 0xfc20 tx timeout
    Bluetooth: hci0: RTL: download fw command failed (-110)

    I also think about blacklist the concerned modules "btusb"(for error1) and "tpm_crb"(for error2), but this will not fix the issues (Bluetooth for example) and will just clear the notifications.

    May be there are another solutions that can help fix these errors and make everything work fine and operationnal.

    Please, could someone Help with suggestions on how to fix these errors?

    Best Regards.

Similar Threads

  1. Replies: 8
    Last Post: 2019-01-12, 21:22

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts