Results 1 to 4 of 4

Thread: psad dependency problem (virtual package)

  1. #1
    Join Date
    2013-Apr
    Posts
    4

    psad dependency problem (virtual package)

    Hello
    Im pretty new linux user, however i started from kali linux. Nevermind. If you will be kind enough to help me solve this problem, i probably wont have similar troubles with other program in future. I tried to solve this by myself, without effects so here it ts
    Today i tried to install psad.
    As root i input aptitude install psad. here is the output (after i installed some required libs manually one by one, but i dont think that it matter):
    Code:
    The following NEW packages will be installed:
      libdate-calc-perl{ab} libunix-syslog-perl{ab} psad 
    0 packages upgraded, 3 newly installed, 0 to remove and 1 not upgraded.
    Need to get 502 kB of archives. After unpacking 1,724 kB will be used.
    The following packages have unmet dependencies:
     libdate-calc-perl : Depends: perlapi-5.10.1 which is a virtual package.
                         Depends: libbit-vector-perl (>= 7.0) but it is not going to be installed.
     libunix-syslog-perl : Depends: perlapi-5.10.0 which is a virtual package.
    The following actions will resolve these dependencies:
    
         Keep the following packages at their current version:
    1)     libdate-calc-perl [Not Installed]                  
    2)     libunix-syslog-perl [Not Installed]                
    3)     psad [Not Installed]                               
    
    
    
    Accept this solution? [Y/n/q/?]
    Im linux begginer, but it isnt hard to find out that the part that mess everything up is perlapi dependency. I cant download anything else that psad require without it, and i cant download perlapi, im stuck.
    Thanks in advance and sorry for grammar and vocabulary as im not english native speaker.

  2. #2
    Join Date
    2013-Apr
    Posts
    126
    If you wanna install psad open a terminal and try this:

    wget http://cipherdyne.org/psad/download/psad-2.2.1.tar.bz2

    tar xvf psad-2.2.1.tar.bz2

    cd psad-2.2.1

    perl install.pl
    good luck

  3. #3
    Join Date
    2013-Apr
    Posts
    4
    Somebody on irc told me that installing like this can mess up system, however i tried it and everything is fine, so thank you..

  4. #4
    Join Date
    2013-Apr
    Posts
    126
    Quote Originally Posted by moh View Post
    Somebody on irc told me that installing like this can mess up system, however i tried it and everything is fine, so thank you..
    Yep, that's why it's always recommanded to use apt-get

Similar Threads

  1. Beef-xss dependency problem
    By muddy in forum ARM Archive
    Replies: 0
    Last Post: 2018-01-25, 16:36
  2. Broken installation- unmet dependency of package libreoffice
    By mithz in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2017-12-18, 04:02
  3. Replies: 0
    Last Post: 2015-06-30, 03:10
  4. Cannot Update - Multiple Dependency problem.
    By thewooster in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-05-02, 14:27

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •