Results 1 to 1 of 1

Thread: Pi3 Keeps Freezing When Data is Flowing Through the WiFi Ports.

  1. #1
    Join Date

    Unhappy Pi3 Keeps Freezing When Data is Flowing Through the WiFi Ports.

    My Pi keeps freezing when plenty of data is flowing through the ports


    Fixed it, I went old school and deleted network manager, then went with wpa_supplicant to handle all my wifi connection needs.

    This post says it all, worked a charm, here you are -

    No more freezes, no more problems at all.

    Happy hacking, folks.

    Another edit -

    I couldn't leave it alone, so I:

    1. Re-installed NetworkManager:
      sudo apt-get install network-manager-gnome network-manager
    2. Then I removed WICD:
      sudo apt-get autoremove wicd wicd-gtk
    3. I then rebooted
    4. Confirm everything is working, then I removed WICD config files (though nothing to remove):
      sudo dpkg --purge wicd wicd-gtk
      In retrospect, seems my problem was installing WICD.

      That's it, no problems, only solutions.

    Hello folks,

    First post from me, here we go...

    I think that Network Manager is my problem.

    From the beginning, Kali would freeze after several hours of use. Could be 10 minutes, could be a couple of hours. I was using it on the road, tethered to my phone, whatever I was running via SSH would freeze, Wifite, Besside-NG, whatever. I thought it has crashed,

    No route to host
    So I did the only thing I could, I yanked out the power cable.

    I've looked at the problem for a week now, it isn't the Pi uptime, it isn't a random error. It happens if I run plenty data through any of my wifi ports.

    I plugged in the HDMI and watched on my TV, complete freeze. everything up, just frozen. ctrl + alt + Fx does nothing.

    Also, if the Pi is up, and I click to change to a different access point, the wifi goes down, I get device not ready, but
    reports they are all there.

    systemctl NetworkManager start
    does nothing, but
    service network-manager restart
    brings back the networking, but it'll connect to one AP, i click to change to another and then it all goes down again.

    I have thought it could be that my USB power adapter cannot handle the Alfa dongle sucking up all that juice to pump out them packets, for on the road I have a huge battery, forget the specs, but it is plenty big (that's very technical, isn't it?)

    What's to do? I don't want to take the cowards' way out and reinstall. It'd be murder reinstalling all the dependencies again.

    Nah, I'll fix it. But how?

    Does anyone have any ideas? Am I missing something obvious?

    Thanks a lot, folks. Talk to you all soon.
    Last edited by monkeybus; 2019-03-19 at 16:59. Reason: I did find the solution to my woes.

Similar Threads

  1. AR9170 wifi monitoring detects almost no data packets
    By Coldfinger in forum General Archive
    Replies: 10
    Last Post: 2016-08-27, 17:08
  2. Kali with 6 COM Ports
    By Thurmus in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-06-17, 17:58

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts