Results 1 to 7 of 7

Thread: 2nd wireless adapter not configurable

  1. #1
    Join Date
    2016-Mar
    Posts
    30

    2nd wireless adapter not configurable

    I am having an issue with a USB RTL8812AU dongle. The laptop has built in wireless and I am trying to install the usb dongle. The system sees it as "Bus 001 Device 002: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac 2T2R DB WLAN Adapter" but it wont list it in the network manager or see it when I do an ifconfig. Anyone have a suggestion on where to get some information on troubleshooting?

  2. #2
    Join Date
    2016-Dec
    Posts
    594
    You need to install the package for it: apt install realtek-rtl88xxau-dkms

    Before you do that, make sure your system is up to date: "apt update && apt dist-upgrade" then reboot.

  3. #3
    Join Date
    2016-Mar
    Posts
    30
    Quote Originally Posted by Mister_X View Post
    You need to install the package for it: apt install realtek-rtl88xxau-dkms

    Before you do that, make sure your system is up to date: "apt update && apt dist-upgrade" then reboot.

    That did not fix the issue. Any other suggestions? I dont see anything in dmesg or the messages file.

  4. #4
    Join Date
    2016-Mar
    Posts
    30
    Quote Originally Posted by quarinteen View Post
    That did not fix the issue. Any other suggestions? I dont see anything in dmesg or the messages file.
    I downloaded to realtek drivers from https://github.com/aircrack-ng/rtl8812au and when I try to install it I get the error

    Your kernel headers for kernel 4.18.0-kali2-amd64 cannot be found at
    /lib/modules/4.18.0-kali2-amd64/build or /lib/modules/4.18.0-kali2-amd64/source.
    Error! echo
    Your kernel headers for kernel 4.18.0-kali2-amd64 cannot be found at
    /lib/modules/4.18.0-kali2-amd64/build or /lib/modules/4.18.0-kali2-amd64/source.


    When I search for my headers I get 4.19.0

    root@kali:~# apt-cache search linux-image
    linux-headers-4.19.0-kali3-amd64 - Header files for Linux 4.19.0-kali3-amd64
    linux-headers-4.19.0-kali3-cloud-amd64 - Header files for Linux 4.19.0-kali3-cloud-amd64
    linux-headers-4.19.0-kali3-rt-amd64 - Header files for Linux 4.19.0-kali3-rt-amd64
    linux-image-4.19.0-kali3-amd64 - Linux 4.19 for 64-bit PCs
    linux-image-4.19.0-kali3-amd64-dbg - Debug symbols for linux-image-4.19.0-kali3-amd64
    linux-image-4.19.0-kali3-cloud-amd64 - Linux 4.19 for x86-64 cloud
    linux-image-4.19.0-kali3-cloud-amd64-dbg - Debug symbols for linux-image-4.19.0-kali3-cloud-amd64
    linux-image-4.19.0-kali3-rt-amd64 - Linux 4.19 for 64-bit PCs, PREEMPT_RT
    linux-image-4.19.0-kali3-rt-amd64-dbg - Debug symbols for linux-image-4.19.0-kali3-rt-amd64
    linux-image-amd64 - Linux for 64-bit PCs (meta-package)
    linux-image-amd64-dbg - Debugging symbols for Linux amd64 configuration (meta-package)
    linux-image-cloud-amd64 - Linux for x86-64 cloud (meta-package)
    linux-image-cloud-amd64-dbg - Debugging symbols for Linux cloud-amd64 configuration (meta-package)
    linux-image-rt-amd64 - Linux for 64-bit PCs (meta-package), PREEMPT_RT
    linux-image-rt-amd64-dbg - Debugging symbols for Linux rt-amd64 configuration (meta-package)
    linux-image-4.18.0-kali2-amd64 - Linux 4.18 for 64-bit PCs

    Why is dpkg looking for 4.18?

  5. #5
    Join Date
    2016-Mar
    Posts
    30
    It appears I chose the wrong adapter. Seems there is a ton of problems with the rtl8814AU chip set. I cant find a suitable resolution for me though. It it screaming about kernal headers 4.18.0 and I am using 4.19.0. Dos anyone know if there is a package for 4.19.0?

  6. #6
    Join Date
    2016-Mar
    Posts
    30
    Its looking for /lib/modules/4.18.0-kali2-amd64/source and /lib/modules/4.18.0-kali2-amd64/build. /lib/modules/4.18.0-kali2-amd64/ exists but the only folder in it is kernel. How do I get the other directories and files?

  7. #7
    Join Date
    2016-Dec
    Posts
    594
    That driver is the exact same I pointed at when mentioning the package.

    Installation didn't work because the kernel you have is old. Current is 4.19. Make sure to update as I mentioned already.

Similar Threads

  1. Kali detects USB wireless adapter, but no wireless networks shown
    By reifi in forum TroubleShooting Archive
    Replies: 13
    Last Post: 2017-04-26, 11:57
  2. No wireless card interface while plugging in USB wireless adapter
    By xyq96999 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-09-15, 05:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •