Results 1 to 2 of 2

Thread: Lockscreen not working on cinnamon

  1. #1
    Join Date
    2019-Apr
    Posts
    2

    Lockscreen not working on cinnamon

    Hi everyone,
    I use Kali very often on one of my professional computers, and as I use Cinnamon on my personnal laptop, so I decided to install it on my Kali. Eveythings works quite well except the lockscreen.
    As mentionned in this thread, when logged in as root (I didn't set a regular user, don't need to), the lockscreen doesn't actually locks the screen, it displays the clock but if you move the mouse or touch the keyboard, it doesn't prompt for password. I suppose that there's a workaround as the lockscreen work with Gnome. Maybe by changing the binary associated wih the keybind ?
    I've also tried with xscreensaver and as expected, it displays:

    Code:
    No protocol specified
    xscreensaver: 17:07:18: Can't open display: :1
    xscreensaver: 17:07:18: initial effective uid/gid was root/root (0/0)
    xscreensaver: 17:07:18: running as nobody/nogroup (65534/65534)
    
    xscreensaver: 17:07:18: This is probably because you're logging in as root.  You
                  shouldn't log in as root: you should log in as a normal user,
                  and then `su' as needed.  If you insist on logging in as
                  root, you will have to turn off X's security features before
                  xscreensaver will work.
    
                  Please read the manual and FAQ for more information:
    
                  https://www.jwz.org/xscreensaver/faq.html
                  https://www.jwz.org/xscreensaver/man.html
    As suggested, the workaround "xhosts +x" doesn't works (I know, there's some security issues but I don't care as it is only a pentest laptop).

    I've also tried to find the binary used by Gnome (maybe specific to Kali as gnome-screensaver is not installed by default), but the only reference I found is "/usr/lib/gnome-settings-daemon/gsd-screensaver-proxy" and I was unable to launch it in my cinnamon session.

    Does anyone know how I can fix it ?

    Thanks !

  2. #2
    Join Date
    2019-Apr
    Posts
    2
    I finally found with binary is launched (I think): xdg-screensaver.

    I've tried it on Cinnamon but is doesn't works either...

Similar Threads

  1. Please help to set Cinnamon as default
    By petgil in forum General Archive
    Replies: 2
    Last Post: 2017-02-16, 16:29
  2. Lockscreen not working in alternative desktops
    By guarin in forum General Archive
    Replies: 0
    Last Post: 2015-10-05, 13:20

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •