Results 1 to 3 of 3

Thread: Pi3 B+ - Can create a wireless hotspot but no devices will connect.

  1. #1
    Join Date
    United Kingdom

    Pi3 B+ - Can create a wireless hotspot but no devices will connect.

    Hi guys.

    I'm trying to set up a shared folder between my windows desktop and a Pi3 running Kali which I am using for cross-platform deployment testing and general networking tomfoolery.

    The problem I have is that due to the corporate environment security settings I cannot view shared folders from windows, so as a workaround I am making use of this:

    I have the pi zero working perfectly, and have been using it to host my 3d printing files at home so I know this is stable.
    What I am trying to do is create a wireless hotspot from the pi3, and have the zero w connect to this hotspot whilst the USB is plugged into the windows machine, thus creating a drop and draggable shared folder.

    My problem is that when I create a hotspot through the network manager GUI the hotspot appears, but when I try to connect from any other device (android phone, pi zero, windows machine) they all repeatedly attempt to connect but will not actually do so.
    (see my ignored SE question here:

    As a result of this I tried to delete the hotspot configuration but the hotspot persisted even after restarting the network card and then the whole machine.
    So I reimaged, and tried again using this tutorial:

    However, when I get to the part where I am trying to give the instruction
    sudo iw phy phy0 interface add mon0 type monitor && ifconfig mon0 upI get
    command failed: Operation not supported (-95)
    Note that I am NOT trying to bridge the main corporate network to my small wifi network, though this may not neccessarily be a bad thing.
    I have managed to connect the windows machine, pi zero, and pi3 to a hotspot created on my phone and have them all ping each other so I know all of the wireless cards do at least WORK.

    Unfortunately I am very much a novice with linux and networking, and am learning on the job (my job requires me to be a bit of a jack of all trades including hardware design and embedded software, which is where I have more experience) so you might have to be patient with me, but I think I am (hopefully) headed in the right direction at least?

    Any help would be greatly appreciated.

  2. #2
    Join Date
    fruitywifi maybe

  3. #3
    Join Date
    United Kingdom
    My workaround to this has been to create a small network hosted on a pi-zero w and use another pi-zero-w set up like this:

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts