Results 1 to 3 of 3

Thread: How do I get .net Core runtime working on pi B3+?

  1. #1
    Join Date
    2019-May
    Location
    United Kingdom
    Posts
    4

    How do I get .net Core runtime working on pi B3+?

    Hi guys,

    I am trying to test some cross-platform code on kali and need to get the .net core runtime environment configured on my pib3+.
    I've tried following this guys video:
    https://www.***********************PFQiUo9loDA (Youtube : "Linux - 3. How to Install Visual Studio Code and .Net Core to Kali Linux")

    But I am getting
    "Cannot execute binary file: Exec format error" at dotnet --info step.I assume this is a processor architecture issue. Tried again with the arm64 version, also to no avail.

    Can anyone help out?
    I feel like .net core is something that should definitely be very accessible since it opens up so much more software compatibility if it is indeed compatible at all!



  2. #2
    Join Date
    2014-Feb
    Posts
    243
    Quote Originally Posted by GigaJoules View Post
    Hi guys,

    I am trying to test some cross-platform code on kali and need to get the .net core runtime environment configured on my pib3+.
    I've tried following this guys video:
    https://www.***********************PFQiUo9loDA (Youtube : "Linux - 3. How to Install Visual Studio Code and .Net Core to Kali Linux")

    But I am getting
    "Cannot execute binary file: Exec format error" at dotnet --info step.I assume this is a processor architecture issue. Tried again with the arm64 version, also to no avail.

    Can anyone help out?
    I feel like .net core is something that should definitely be very accessible since it opens up so much more software compatibility if it is indeed compatible at all!


    .net core *should* be accessible, however, the build system for it is..... convoluted. That said... the version you need will depend on what image you are using. If you're using the typical "rpi3-nexmon" image for the rpi3, you're going to need the arm32/armhf version of the .net core files. If you're using "rpi3-64" then the arm64 version should work. If however, the installation does some downloading... then typically you run into upstream making assumptions that "this device is 64bit so it should download an amd64 version of the binary" - we can't help with that, and you'd have to poke the upstream project and tell them they need to fix their script (or better, since it's open source, provide them with a patch that actually checks between aarch64 and x86_64...

    Sorry if this wasn't informative or helpful enough, but knowing what base image you're using should be the first step.

  3. #3
    Join Date
    2019-Jan
    Posts
    39
    convoluted. nice a ten dollar euphimism

Similar Threads

  1. Install Intel Open runtime
    By w3soul in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2018-07-29, 22:24
  2. Nethunter 3.0 OnePlusOne - CreateChroot Java Runtime Error
    By QwerHunter in forum NetHunter General Questions
    Replies: 3
    Last Post: 2016-04-17, 05:24
  3. lsb-core isn't include on Kali 2016.1??
    By Felarof in forum General Archive
    Replies: 2
    Last Post: 2016-03-10, 19:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •