Results 1 to 1 of 1

Thread: Kali-linux-2019-2-release cannot reboot

  1. #1
    Join Date

    Kali-linux-2019-2-release cannot reboot

    Linux Orkeven-Kali 4.19.0-kali5-amd64 #1 Debian 4.19.37-2kali1 (2019-05-15) x86_64 GNU/Linux

    No LSB modules are available
    Distributor ID: Kali
    Description: Kali GNU/Linux Rolling
    Release: 2019.2
    Codename: n/a

    I am running kali as a dual boot on a Dell Latitude E6420

    I recently encountered a problem after running apt update during an installation of an epub reader, as when I tried to launch a 3D graphics software it simply didn't launch. I tried launching it in terminal and got an OpenGL error message (check if OpenGL is working). I tried updating OpenGL (mesa package), but it didn't resolve. I tried to install nvidia driver since my GPU is nvidia and this bricked my computer, and I couldn't reboot.
    It was a "failed to load kernel module" error during reboot.

    I was able to resolve this by purging out nvidia and then rebooting.

    I cleared some space of about 10GB on my pc to accommodate more tutorials, after which I thought to perform a dist-upgrade since during my brief research I had noticed a new upgrade for Kali. After the upgrade, I was left with about 8.3GB of free disk space.

    I resumed my tutorials and then when I tried to render an output, halfway through the project, the software froze and didn't respond to my attempts at closing it.
    So, I launched another version of the software and continued the tutorial, as I was afraid something might go wrong if I tried a reboot of the system. I simply wanted to complete the project and hit my deadline.

    While I was working I got a notification that I had about 700+ MB of free space left. Before I could recover from the shock it had become 200MB. I initiated a reboot, during which time it had become 0MB just before the lights went out.

    The reboot failed as I kept on getting "failed to start modem", failed to start hostname.

    This happened two nights ago.

    If anybody knows how to resolve this, it will be appreciated. Thank you.

    I can access terminal via Ctrl-Alt-F3
    apt isn't working, but keeps returning an error that ends with No space left on device.
    Even "rm" didn't work.

    I tried "ls" and it listed the contents of the directory. So, I used "cd" into a folder and tried to delete a file I know is about 20MB with the hope that it will create space, and it did.
    So, I just edited the grub config file (as seen in another thread) and updated rub:
    => nano /etc/default/grub
    => update-grub
    It worked. ☺

    I'm going to reboot and see. But, I wonder what to do about the space that I no longer have.

    **update 👇
    I have rebooted and there is no [Failed] errors anymore, not of the daemon, nor of the modem manager or the hostname service. Everything showed [OK] in green, but it is stuck on "Resuming from hibernation" with a bleeping cursor under.
    It is still stuck.


    Side note: I have been considering ways to simply wipe the slate clean and installing Kali directly over the Internet via terminal, since that was the only access I had. I don't know if such is possible with Linux. I hope it is. That would really make it stand out as a power OS, if a user can simply wget and install a full OS.
    In any case, this led me to consider erasing all files, and reminded me of the clean command.

    Everything I had tried until now would show a "No space left on device" at the end. So, maybe if I could find a way to create space, then I might just be able to resolve it (I was considering running apt update afterward to fix the any redundancy).

    So, I did the following:

    apt clean
    apt autoclean
    apt autoremove
    apt autoremove --purge (to sort out more redundancies, if any)

    All in root mode, of course.
    Done! ☺

    I got my 8+ GB space back as well.

    I think it was the clean that did it. I just did the others to be doubly sure. 😁

    I hope someone finds this helpful in the future, especially to free up space on his/her device.
    Last edited by Orkeven; 2019-06-15 at 17:14.

Similar Threads

  1. kali linux 2019 release time
    By kaliuserdate in forum General Archive
    Replies: 3
    Last Post: 2019-01-22, 16:02
  2. Kali Linux 1.0.7 Release?
    By JimboV in forum General Archive
    Replies: 17
    Last Post: 2014-06-04, 09:28

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts