Results 1 to 3 of 3

Thread: No sound No menu in KALI

  1. #1
    Join Date
    2019-Jul
    Posts
    1

    No sound No menu in KALI

    good morning

    I was use HDMI as output device Also i use my Laptop or headset them i got update after that the sound doesn't work at all so i tried to fix it and i get more problems

    First I tried this
    Code:
    1. Turn on Kali Linux, open terminal and type in sudo killall pulseaudio and hit enter. Now type next.
    
    sudo apt-get purge pulseaudio pulseaudio-utils gstreamer0.10-pulseaudio paman pavumeter pavucontrol
    
    and again hit enter.
    2. Continue typing and now type  rm ~/ .pulse-cookie , after that type rm -r ~/ .pulse and after this type next.
    
    sudo apt-get install alsa-base alsa-tools alsa-tools-gui alsa-utils alsa-oss alsamixergui libalsaplayer0
    
    and at last type apt-get install kmix and hit enter.
    3. And now restart machine.
    4. OK now again open terminal and start typing on terminal and type next  apt-get install pulseaudio and hit enter and and last type apt-get  install gnome-core and again hit enter.
    5. Restart machine.
    BUT I LOST ALL MY FILES AND ITS DIDNT WORK
    MY LAPTOP LOOKS LIKE ITS NEW !


    I tried this also

    Code:
    curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh | bash
    I tried many solution and I get more problems such as menu i deleted it and i couldn't install it again

    here is sound settings
    Attachment 3471


    as you can see the menu is deleted

    here when i tried to install it again
    Attachment 3472


    thank you for helping me and sorry for my bad language i hope you understand me

  2. #2
    Join Date
    2019-Jul
    Posts
    1
    Having just installed Kali Linux on my Raspberry Pi 3b+ for the first time (I am also a newbie) where I was not only frustrated by not being unable to sort out the lack of audio, but when I checked across the various forums and websites it appears that audio does not work within Kali, where even these threads seem to be unable to provide any worthwhile information.
    So, I take it that audio is a sort of hit and miss feature within Kali as there does not seem to be any fix?

  3. #3
    Join Date
    2016-Dec
    Posts
    647
    None of the commands should have erased files. The problem may be your command

    rm ~/ .pulse-cookie
    There is a space between the '/' and '.pulse-cookie'. It shouldn't erase stuff, but you might have used different flags with rm that forced delete the files in there.

Similar Threads

  1. Replies: 4
    Last Post: 2018-06-21, 11:39
  2. Kali playing system sound but no browser or other app sound
    By dmans in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2018-04-28, 17:51
  3. Usb Headset don't appear in sound menu, but listed in lsusb
    By HighPoint in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2017-06-16, 07:24
  4. Replies: 2
    Last Post: 2015-05-14, 08:04
  5. Replies: 1
    Last Post: 2014-03-19, 03:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •