Results 1 to 4 of 4

Thread: Kali linux not starting on Raspberry Pi 3 B v2

  1. #1
    Join Date

    Talking Kali linux not starting on Raspberry Pi 3 B v2 [SOLVED]

    Hello Kali forums,

    I recently got a Raspberry Pi 3 B v2 and decided I wanted to try and install kali on it. Naturally I went to the kali documentation and follow the instructions to setup a boot-able micro-sd-card. Unfortunately it did not work. After inserting the sd-card and plugging in the Pi, nothing happened. No display, no disk activity, nothing, just the red power light. I was wondering if anyone had any suggestions on how I might get this to work since I've seen several threads on successful attempts. I've provided instructions on what I have tried below to help pin-point the problem.

    Installation attempts

    1: I installed the latest kali ARM version for the Pi 3. [Kali Linux RaspberryPi 2, 3 and 4 32 bit]

    2: Once downloaded I moved it to my kali linux vm using a usb drive.

    3. Then following the command used on the documentation, (xzcat kali-$version-rpi2.img.xz |ddof=/dev/sdb bs=512k)I wrote the image to my micro-sd-card which was plugged into my computer via a usb adapted I had.

    4: After the process was done I inserted it into my raspberry Pi and plugged it in.

    I have also tried this with a unzipped version and with the 64bit version all with the same results. The application I used to unzip the image was 7zip and the archive manager that comes with kali linux.

    The issue was the tool I was using to write the image to the sd-card. Thank you webbsmurfen for helping me solve this problem!
    Last edited by CodeDev1809; 2019-07-24 at 22:34.

  2. #2
    Join Date
    Why complicate things?

    You're using windows, right?

    Use rufus

    Download/install and write to SD-card


  3. #3
    Join Date
    Ok, so instead of using kali try one of those. Gotcha! I'll try that!

  4. #4
    Join Date
    It worked! Thanks!

Similar Threads

  1. starting with kali linux instead of windows
    By coolmaster in forum Installing Archive
    Replies: 2
    Last Post: 2015-05-07, 18:55

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts