Results 1 to 3 of 3

Thread: Alfa AWUS036ACH airodump-ng need help

  1. #1
    Join Date
    2019-Jul
    Posts
    2

    Alfa AWUS036ACH airodump-ng need help

    Hi there!


    I'm having a big problem recently. I'm trying to build a mobile wifi pentester device using a Raspberry pi.
    I have a pi 4 with 4GB ram.
    Installed with StickyFingers-Kali-Pi-armhf-190703 (from https://re4son-kernel.com/re4son-pi-kernel/).


    I bought an Alfa AWUS036ACH from Amazon.
    When I'm using with airodump-ng I get poor results, and most of the time I get a message in the top line saying "interface wlan1 is down".
    I have realtek-rtl88xxau-dkms (driver) installed.
    What I mean about poor results: If I connect the card to a win10 machine, and click at the wireless thing in the taskbar, I get much more wireless network than when I use it in kali with airodump-ng.
    I tried to boost up the tx-power to 30dbi from the basic 18, but it doesn't help anything.


    My main surprise is that I also have a TP-LINK TL-WN722N (it is a lot smaller 2.4 GHZ adapter) and it's JUST WORKS.
    Out of the box without any driver installed, or any extra work required.


    I can attach a big (9dbi) antenna to it, and it work with that as well, without any tx-power magic or anything.
    When scanning for networks it does NOT disconnect randomly like the alfa one.


    Please send help to deal with that.

  2. #2
    Join Date
    2016-Dec
    Posts
    647
    You should compare apples to apples. Windows and Linux drivers are completely different beasts. Does it behave differently on a x86 (or 64 bit) Kali?

    The reason WN722N works well is because it's a driver provided in the Linux Kernel and to top it off, its firmware is open source. The rtl8812/14au's driver is a modification of the vendor's driver. It is still being worked on.

    To address the antenna situation, when a device has multiple connectors, the same antenna should be used on all of them. Also, don't get directional antennas for them, that will most likely result in poor results since the chipset hasn't been tuned for that situation.

    To address the kernel, I'm pretty sure the reason kernel is already in the Kali image.

  3. #3
    Join Date
    2019-Jul
    Posts
    2
    I missed some information about the post:

    I use usb 3.0 for the Alfa card. My antennas are omnidirectional.

    Before the raspberry, I use the Alfa card in a virtual install of kali (Oracle Virtualbox), but it didn' t work there either. I had the same problems as I described above.
    I thought the problem is the virtualization environment. That is one of the reasons why I tried to make the Raspberry.

    The Kernel is inside kali in some way, but the bluetooth command soe not seems to work as easy as it does on the sticky.

Similar Threads

  1. Alfa awus1900 OR awus036ach
    By wolfsta in forum Kali Linux General Questions
    Replies: 1
    Last Post: 2018-12-22, 13:08
  2. New Alfa awus036ach help
    By fatfarm5 in forum TroubleShooting Archive
    Replies: 47
    Last Post: 2017-12-14, 10:47

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •