Results 1 to 9 of 9

Thread: Realtek RTL8812BU Driver for Kali Linux

  1. #1
    Join Date
    2019-Aug
    Posts
    1

    Realtek RTL8812BU Driver for Kali Linux

    Hello all,

    Just felt I'd throw this out there as I had this issue so surely someone else will too.

    How to get the Realtek RTL8812BU driver installed on Kali (Kernel 4.19.28-2 at time of writing)

    From a 100% fresh install, connected to the internet (via NAT Network or whatever), run the following commands:
    Code:
    apt update
    apt install bc -y
    git clone https://github.com/cilynx/rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959.git
    cd rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959
    VER=$(sed -n 's/\PACKAGE_VERSION="\(.*\)"/\1/p' dkms.conf)
    sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER}
    sudo dkms add -m rtl88x2bu -v ${VER}
    sudo dkms build -m rtl88x2bu -v ${VER}
    sudo dkms install -m rtl88x2bu -v ${VER}
    sudo modprobe 88x2bu
    After running all that, you should see your 8812BU in ifconfig and you should be able to monitor and packet inject with it.

    Note: With time, the author of the driver may make a new major release, so be sure to check for a new repo at https://github.com/cilynx/

    Cheers guys

  2. #2
    Join Date
    2015-Aug
    Posts
    15
    How did you test monitor and inject?

    In my just full-upgraded Kali VM 64:
    Code:
    root@kali:~# airmon-ng check kill && airmon-ng start wlan0
    PHY	Interface	Driver		Chipset
    phy1	wlan0		rtl88x2bu	Realtek Semiconductor Corp. 802.11ac NIC
    ERROR adding monitor mode interface: command failed: Operation not supported (-95)

  3. #3
    Join Date
    2019-Oct
    Posts
    1

    TP-LINK Archer AC1300 T4U V3 Monitor mode

    Quote Originally Posted by ovosodo View Post
    How did you test monitor and inject?

    In my just full-upgraded Kali VM 64:
    Code:
    root@kali:~# airmon-ng check kill && airmon-ng start wlan0
    PHY    Interface    Driver        Chipset
    phy1    wlan0        rtl88x2bu    Realtek Semiconductor Corp. 802.11ac NIC
    ERROR adding monitor mode interface: command failed: Operation not supported (-95)
    Hi Guys,

    I am running into the exact same issue any suggestions will be highly appreciated.

  4. #4
    Join Date
    2019-Nov
    Posts
    1
    This driver also work with RTL8812AU. To enable monitor mode. start fluxion "./fluxion.sh" enter option 2 for capturing handshake. After the wifi adapter is initialised. open another terminal tab. Then you can enter "airodump-ng fluxwl0".

  5. #5
    Join Date
    2019-Nov
    Posts
    1

    Lightbulb I hope it will help you with enabling monitor mode.

    I think you can also use this method to enable monitor mode -
    Code:
    root@kali:~#ifconfig wlan0 down
    root@kali:~#airmon-ng check kill
    root@kali:~#iwconfig wlan0 mode monitor
    root@kali:~#ifconfig wlan0 up
    root@kali:~#airodump-ng --band a --channel 2 -- write output wlan0
    Feather you can see if interface is in monitor mode by typing this:
    root@kali:~#iwconfig wlan0
    wlan0 is an [interface]

  6. #6
    Join Date
    2019-Dec
    Posts
    5
    Here?s how to solve the wifi problem:
    This is how I managed it to work on ParrotOS with latest 5.3 kernels.
    This should also work with Kali Linux 2019.4 + latest kernels.

    I also managed to get the TX-power to 30db. I will post instructions later today.


    Ok, one way to get it running is this:


    From clean ParrotOS 4.7 with all updates loaded:

    1. go to /lib/firmware/
    2. here you will need to create a folder named rtw88
    3. go to /lib/firmware/rtlwifi/
    4. here you will need to copy the file rtl8822befw.bin
    5. go to /lib/firmware/rtw88/
    6. here you will need to insert the file you just copied (rtl8822befw.bin)
    7. now you will need to rename the file to rtw8822b_fw.bin
    8. reboot your system

    Now your network manager should be able use your rtl8822be wifi adapter without any problems.


    Right now my ParrotOS has two bluetooth symbols in the task line but wifi is working.

    Now I will try to correct the exta bluetooth symbol.


    I?ll keep you up to date.



    veo

  7. #7
    Join Date
    2020-Jan
    Posts
    2

    repository not found

    Hello,
    When i tried the above written code ,I am getting an error saying that 'repository not found' . any help to resolve this will be much appreciated.

  8. #8
    Join Date
    2020-Jan
    Posts
    2
    Hello,
    when I tried the above code ,I am getting an error message "repository not found" any help to resolve this will be much appreciated.
    thanks

  9. #9
    Join Date
    2020-Feb
    Posts
    2
    Monitor mode works fine that way, the problem is raven.. I find this that worked for me:

    Code:
    apt-get purge --auto remove reaver
    apt-get install sqlite3 lisqlite3-dev libcap0.8-dev
    then follow the steps for install reaver on https://github.com/t6x/reaver-wps-fork-t6x

    Credits: zsecurity.org

Similar Threads

  1. Plz Help ! Cannot install Realtek 8191SU USB Wireless lan driver
    By a340090 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2014-09-15, 15:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •