Results 1 to 5 of 5

Thread: Slow wireless speed connection

  1. #1
    Join Date
    2019-Aug
    Posts
    3

    Slow wireless speed connection

    Hello!


    I have some problems with wireless speed connection (~3 Mbit/sec max), but on windows i have ~30 Mbits/sec. Kali is freshly installed and driver is also exists. Wireless adapter AWUS036HN (RT2870/RT3070) + another noname adapter with the same chipset.


    lsusb
    Bus 001 Device 003: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
    Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


    lsmod
    Module Size Used by
    ctr 16384 4
    ccm 20480 6
    nls_utf8 16384 1
    isofs 45056 1
    udf 102400 0
    crc_itu_t 16384 1 udf
    fuse 122880 4
    vboxvideo 45056 0
    arc4 16384 2
    rt2800usb 32768 0
    rt2x00usb 24576 1 rt2800usb
    rt2800lib 118784 1 rt2800usb


    Tried these methods, but it didn't help:
    https://forums.kali.org/showthread.p...er-Wi-Fi(WLAN)
    https://ubuntuforums.org/showthread.php?t=1877120


    Any ideas?


    Thank you
    Attached Images Attached Images

  2. #2
    Join Date
    2019-Aug
    Posts
    3
    I also figured out, that my wireless card always set Bit rate=1
    Tried to change it but unfortunately

    iwconfig
    wlan0 IEEE 802.11 ESSID:"TP-LINK"
    Mode:Managed Frequency:2.452 GHz Access Point:
    Bit Rate=1 Mb/s Tx-Power=20 dBm
    Retry short long limit:2 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff
    Link Quality=70/70 Signal level=-17 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:11 Invalid misc:0 Missed beacon:0

  3. #3
    Join Date
    2016-Dec
    Posts
    647
    iwconfig has been deprecated for years, don't rely on that for information.

    Have you checked dmesg for errors? How's the signal like? How far are you from the AP?

  4. #4
    Join Date
    2019-Aug
    Posts
    3
    There was was no errors related to wifi adapter except these:
    [ 12.251664] [drm:vmw_host_log [vmwgfx]] *ERROR* Failed to send host log message.
    [ 12.255552] [drm:vmw_host_log [vmwgfx]] *ERROR* Failed to send host log message.

    Im near the Ap ~2 meters and signal is OK, but speed is the same...

  5. #5
    Join Date
    2016-Dec
    Posts
    647
    No idea what's wrong, sorry.

Similar Threads

  1. Replies: 2
    Last Post: 2013-12-24, 09:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •