Results 1 to 11 of 11

Thread: Install Powershell on Kali

  1. #1
    Join Date
    2014-Dec
    Location
    Indianapolis, Indiana
    Posts
    54

    Install Powershell on Kali

    Hi, I have Kali 2019.2 64-bit on VMware and Windows 10 Host. I am trying to install PowerShell on my Kali VM. What's the best way of doing that? I've been looking at PowerShell on GitHub. Will "powershell_6.2.2-1.debian.9_amd64.deb" work? Not sure on Kali...I tried earlier but had problems and moved it all to the Trash. I don't remember the errors. I tried the kali.org tutorial.

    echo "deb [arch=amd64] https://packages.microsoft.com/repos...n-stretch-prod stretch main" > /etc/apt/sources.list.d/powershell.list apt update
    apt -y install powershell

    I'm not sure if "microsoft-debian-stretch-prod" is my Kali version. And "apt install powershell" says missing "lib etc... not installable." So how can I install PowerShell? With the newest version of Kali? Please reply. Thanks

  2. #2
    Join Date
    2014-Dec
    Location
    Indianapolis, Indiana
    Posts
    54
    I tried the kali.org tutorial again. Everything works fine till "apt -y install powershell"

    E: Unable to correct problems, you have held broken packages.

    How do I fix this?

  3. #3
    Join Date
    2014-Dec
    Location
    Indianapolis, Indiana
    Posts
    54
    Anyone? How do I fix "broken packages"? I will try "sudo dpkg –configure -a", "sudo apt-get install -f" tomorrow. And try "system tools > add/remove software". Maybe install synaptic. Does Kali have aptitude? I'll report back. Thanks

  4. #4
    Join Date
    2016-Dec
    Posts
    647
    That all depends on the error.

    1. What is the FULL error message? The last sentence is usually useless without the details above (and that's the case for ANY other tool).
    2. aptitude can be installed if not there: apt install aptitude
    3. Update your system: apt update && apt dist-upgrade

  5. #5
    Join Date
    2014-Dec
    Location
    Indianapolis, Indiana
    Posts
    54
    Full message:

    root@kali:~# apt -y install powershell
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    powershell : Depends: libicu57 but it is not installable
    E: Unable to correct problems, you have held broken packages.

  6. #6
    Join Date
    2014-Dec
    Location
    Indianapolis, Indiana
    Posts
    54
    I tried "sudo aptitude -y install powershell." Got a huge error:

    The following NEW packages will be installed:
    liblttng-ust-ctl4{a} liblttng-ust0{a} powershell{b}
    0 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
    Need to get 58.1 MB of archives. After unpacking 159 MB will be used.
    The following packages have unmet dependencies:
    powershell : Depends: libicu57 which is a virtual package and is not provided by any available package

    The following actions will resolve these dependencies:

    Keep the following packages at their current version:
    1) powershell [Not Installed]



    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0 B of archives. After unpacking 0 B will be used.
    W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
    W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
    W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
    W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
    W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
    W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
    W: Target DEP-11-icons-small (main/dep11/icons-48x48.tar) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
    W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1

    And:

    root@kali:~# pwsh
    bash: pwsh: command not found

    I'll try synaptic for broken packages...

  7. #7
    Join Date
    2014-Dec
    Location
    Indianapolis, Indiana
    Posts
    54
    Synaptic didn't work. I tried Edit > Fix Broken Packages and it said Successful but I get the same error above (the long one.) Does anyone know the problem? Here's more:

    root@kali:~# pip install libicu57
    DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/develo...thon-2-support
    Collecting libicu57
    ERROR: Could not find a version that satisfies the requirement libicu57 (from versions: none)
    ERROR: No matching distribution found for libicu57

    And:

    root@kali:~# apt -y install libicu57
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package libicu57 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'libicu57' has no installation candidate

  8. #8
    Join Date
    2014-Dec
    Location
    Indianapolis, Indiana
    Posts
    54
    I'm back. Can anyone take a look and fix the errors? How do I install libicu57? Please reply. Thanks

  9. #9
    Join Date
    2016-Dec
    Posts
    647
    Could you open a detailed bug report on bugs.kali.org and reference this post as well?

  10. #10
    Join Date
    2014-Dec
    Location
    Indianapolis, Indiana
    Posts
    54
    Sure, I'll do it tomorrow.

  11. #11
    Join Date
    2014-Dec
    Location
    Indianapolis, Indiana
    Posts
    54
    bugs.kali.org worked. I installed libicu57 and it worked. I have PowerShell now. Thanks for the help!

Similar Threads

  1. XFCE Desktop from Powershell with WSL success.
    By revoltrise in forum Installing Archive
    Replies: 0
    Last Post: 2018-04-25, 07:26
  2. HID attack Crashes with powershell
    By Cylon_Avenger in forum NetHunter General Questions
    Replies: 0
    Last Post: 2015-05-02, 18:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •