Results 1 to 2 of 2

Thread: Tx-power= 0 dBm on wlan0mon when monitoring; but Tx-power = 20 dBm on Wlan0 when managed. Help!

  1. #1
    Join Date

    Tx-power= 0 dBm on wlan0mon when monitoring; but Tx-power = 20 dBm on Wlan0 when managed. Help!

    Hey everyone!

    I have an issue trying to set my power to 20 when I'm monitoring. I'm using Kali lastest version from a Live CD (USB) and as chipset a Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter built-in my laptop to monitor. So here is the info:

    root@kali:~# iwconfig
    eth0 no wireless extensions.

    wlan0 IEEE 802.11 ESSID:"Ever's House"
    Mode:Managed Frequency:2.417 GHz Access Point: 2C:9D:1E:E3:FC:80
    Bit Rate=1 Mb/s Tx-Power=20 dBm
    Retry short limit:7 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementn
    Link Quality=58/70 Signal level=-52 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:13 Missed beacon:0

    lo no wireless extensions.

    sudo iw list
    * 2412 MHz [1] (20.0 dBm)
    * 2417 MHz [2] (20.0 dBm)
    * 2422 MHz [3] (20.0 dBm)
    * 2427 MHz [4] (20.0 dBm)
    * 2432 MHz [5] (20.0 dBm)
    * 2437 MHz [6] (20.0 dBm)
    * 2442 MHz [7] (20.0 dBm)
    * 2447 MHz [8] (20.0 dBm)
    * 2452 MHz [9] (20.0 dBm)
    * 2457 MHz [10] (20.0 dBm)
    * 2462 MHz [11] (20.0 dBm)
    * 2467 MHz [12] (20.0 dBm)
    * 2472 MHz [13] (disabled)
    * 2484 MHz [14] (disabled)
    sudo iw dev
    Interface wlan0
    ifindex 3
    wdev 0x1
    addr 9c:b6:d0:0d:4b:b5
    ssid Ever's House
    type managed
    channel 2 (2417 MHz), width: 20 MHz, center1: 2417 MHz
    txpower 20.00 dBm
    multicast TXQ:
    BUT THEN... when then i try to monitor here is what happens

    airmon-ng start wlan0
    Found 3 processes that could cause trouble.
    Kill them using 'airman-ng check kill' before putting
    the card in monitor mode, they will interfere by changing channels
    and sometimes putting the interface back in managed mode

    PID Name
    3902 NetworkManager
    3918 wpa_supplicant
    3923 dhclient

    PHY Interface Driver Chipset

    phy0 wlan0 ath10k_pci Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

    (mac80211 monitor mode vif enabled for [phy0]wlan0 on [phy0]wlan0mon)
    (mac80211 station mode vif disabled for [phy0]wlan0)
    then i kill those processes and then

    eth0 no wireless extensions.

    wlan0mon IEEE 802.11 Mode:Monitor Frequency:2.457 GHz Tx-Power=0 dBm
    Retry short limit:7 RTS thrff Fragment thrff
    Power Managementn

    lo no wireless extensions.
    Power goes to zero. Any idea how I can fix it? I believe this is the issue why ii dont get any BSSID when I use after listening for a while with

    airodump-ng wlan0mon
    CH 3 ][ Elapsed: 4 mins ][ 2019-08-04 17:26


    BSSID STATION PWR Rate Lost Frames Probe

    Nevertheless with I switch to manage mode everything is ok and it gets connection to my test wifi: Ever's House. So what I can do to fix this? Thank guys!
    Last edited by FallenSnipa; 2019-08-05 at 03:40.

  2. #2
    Join Date
    That card is utter garbage due to its firmware crashing constantly, and there have been countless reports that it doesn't capture anything, you can also search that QCA number in the Aircrack-ng forums, you'll see.

    To fix it, change the wireless card or get a USB card. There are a few recommendations in the Aircrack-ng FAQ.

    Another thing, the what is shown by iwconfig is just information, it can be inaccurate, as it has been deprecated for years.

    Btw, next time, could you make sure to post in the appropriate section? This isn't a howto

Similar Threads

  1. AWUS036NHR v.2 - TX Power
    By DoubleDD in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-01-09, 14:46
  2. Raising TX Power - What Does This Really Do?
    By kalikali in forum General Archive
    Replies: 0
    Last Post: 2015-12-17, 20:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts