Results 1 to 2 of 2

Thread: kali-tools-vulnerability dependency issue with Ace

  1. #1
    Join Date

    Exclamation kali-tools-vulnerability dependency issue with Ace

    Recently after getting a Wi-Fi, I used this:
    apt -get update && apt-get install kali-linux-all
    to get all the available meta-packages for Kali Linux on my system.

    But after the 15Gb file installation, 1 file is causing errors in my kali-tools-vulnerability package, named as ace.

    Terminal keeps prompting me to use this:
    apt --fix-broken install
    But even after using the code, it gives me this error:

    root@AbbyLinux:~# apt --fix-broken install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following package was automatically installed and is no longer required:
    Use 'apt autoremove' to remove it.
    The following additional packages will be installed:
    Suggested packages:
    The following NEW packages will be installed:
    0 upgraded, 1 newly installed, 0 to remove and 920 not upgraded.
    869 not fully installed or removed.
    Need to get 0 B/891 kB of archives.
    After this operation, 3,072 kB of additional disk space will be used.
    Do you want to continue? [Y/n]
    And after pressing "Y", the following happens:

    (Reading database ... 532899 files and directories currently installed.)
    Preparing to unpack .../ace_0.0.5-3+b11_amd64.deb ...
    Unpacking ace (0.0.5-3+b11) ...
    dpkg: error processing archive /var/cache/apt/archives/ace_0.0.5-3+b11_amd64.deb (--unpack):
     trying to overwrite '/usr/bin/ace', which is also in package ace-voip 1.10-1kali5
    dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Because of this, I am kind of stuck as I am not even able to use this: apt autoremove
    Tried googling for 3-4 days but in vain.

  2. #2
    Join Date
    I was having the same issue and I found something that seemed to help. Give this a shot and I hope that helps. This worked for me and it allowed me to finally upgrade.

    Step 1:
    apt --fix-broken install
    Step: 2 (once you run the fix above and it breaks, look for the ace.....deb output that failed and copy it and paste it in place of mine below if it is different)
     sudo dpkg -i --force-overwrite /var/cache/apt/archives/ace_0.0.5-3+b11_amd64.deb
    Last edited by Retnuh; 2019-08-17 at 00:57.

Similar Threads

  1. Replies: 0
    Last Post: 2020-04-23, 05:49

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts