Results 1 to 2 of 2

Thread: Kali Linux 2019.2 - Surface Go - ATH10K QCA6174 WiFi - No WiFi Network

  1. #1
    Join Date
    2019-Aug
    Posts
    1

    Kali Linux 2019.2 - Surface Go - ATH10K QCA6174 WiFi - No WiFi Network

    Hi,


    I'm a newbie to Kali Linux.


    Recently installed Kali Linux 2019.2 64-bit on my Microsoft Surface Go, overwriting the previous Ubuntu installation.


    During the installation, I got the following error:


    ***
    Some of your hardware needs non-free firmware files to operate. The firmware can be loaded from removable storage.
    The missing firmware files are: ath10k/pre-cal-pci-0000:01:00:0.bin ath10k/cal-pci-0000:01:00.0.bin
    If you have such media available now, insert it , and continue.
    ***


    As per a fairly lengthy search on the Internet, I concluded that these supposedly calibration files are optional & I need not worry.


    The installation completed successfully apart from the inability to update during the install. I have a Dell DA200 USB Type C adapter, enabling me to use wired Ethernet, however, the update process doesn't work despite Internet access, but that's a separate issue.


    Anyway... Everything else worked, except for WiFi. It showed WiFi as available, however, could not search for any Networks. A few months back when I installed Ubuntu, I had run into the WiFi issue as well & had solved it, however, I unfortunately didn't keep notes on whee I used the updated firmware files from. And this time I was searching from Kali linux perspective.


    After multiple hours of browsing online forums & trying updated linux firmware from Git repository 'https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/' & Kvalo's ATH10K firmware files 'https://github.com/kvalo/ath10k-firmware', I kind of gave up. I had tried replacing multiple files like board.bin, board-2.bin, firmware-4.bin, firmware-6.bin etc. The files from kernel.org are the same as the ones already present in Kali Linux 2019.2, same checksums. The files by kvalo however, are of very different file size & resulted in Kali Linux not being able to load the files at all as checked by 'dmesg | grep ath10k'.


    Tried my luck again with Google the next day, searched from Ubuntu perspective & came across this page 'https://www.beesbot.com/microsoft-surface-go-ubuntu/'.


    Basically it says to use the 'board.bin' file from 'http://www.killernetworking.com/support/K1535_Debian/board.bin', Checksum: SHA256: E79B80E2243C62F41FBAF1CC92845CEFB11019B0A6D1C91488 CF43FD63DCF85C. I didn't even need to mess with the conf files, just replacing the 'board.bin' file in '/lib/firmware/ath10k/QCA6174/hw3.0/' did the trick. Looks like the 'board.bin' file for 'Killer? Wireless-AC 1535' works for QCA6174 chipset.


    Now the official website 'https://support.killernetworking.com/knowledge-base/linux-support/' links back to linux drivers at kernel.org which I already tried above. The board.bin file at kernel.org is ~64kB, while the one from Killer's website is ~8kB.


    So not sure what this board.bin file is for, however, it seems to work wonders for QCA6174.


    Hope it helps someone else having these issues.


    Thanks,
    Jp

  2. #2
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    956
    Show the output of rfkill list all and lsmod?

Similar Threads

  1. Kali 2.0 Surface Pro 2 Wifi Issue
    By boost in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-08-16, 03:34
  2. Replies: 2
    Last Post: 2014-08-01, 07:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •