Results 1 to 33 of 33

Thread: rtl8822be wifi not working after updated to kernel 5.2.0

  1. #1
    Join Date
    2013-Apr
    Posts
    182

    rtl8822be wifi not working after updated to kernel 5.2.0

    after i upgrade 4.19 to 5.2.0 , the wifi don't working any more ,

    and 4.19 kernel is working well .

    is there some one can help with this issue ?

  2. #2
    Join Date
    2013-Apr
    Posts
    182
    wifi net work always scanning ,but no wifi can be connected in the list

  3. #3
    Join Date
    2019-Aug
    Posts
    1
    Quote Originally Posted by when123 View Post
    after i upgrade 4.19 to 5.2.0 , the wifi don't working any more ,

    and 4.19 kernel is working well .

    is there some one can help with this issue ?

    Well i have the exact same problem on parrot os after upgrading to 5.2.0 and it works fine on the previous version and i have the same card as you it seems like it's major

  4. #4
    Join Date
    2016-Dec
    Posts
    806
    Anything in dmesg?

  5. #5
    Join Date
    2019-Sep
    Posts
    1

    I managed to fix it

    Hi! I've been dealing with this error for the past two days and finally managed to solve it. I'll try to guide everyone through the steps, but consider I'm pretty new to kali/linux so some steps might be unnecesary or even changed to fit your own system.
    I installed Kali and wifi worked perfectly until I did a dist-upgrade. The only reason I did it was because it was recommended by kali documentation when trying to install nvidia drivers. After getting kernel 5.2.0 wifi was gone, not even detected in iwconfig, but my device was listed using;

    Code:
    lshw -C network
    I followed the instructions on https://github.com/lwfinger/rtlwifi_new to install the drivers for rtl8822be, and then it was kinda detected, it was showing on my network manager but not finding any networks. It was now listed in iwfconfig under the DISABLED flag (or something like that).
    In order to be as precise as I can regarding to what I did, I must say I tried to uninstall these drivers (make uninstall etc...), removing them from the modules list, though they popped in again on every reboot.
    So, at this point I started checking the logs and found out 3 things:
    1. On every system startup i had an Error regarding network devices not being able to raise or something like that.
    2. On the logs i had a halmac_init_hal failed error. But looking for that and trying out solutions didn't actually solve anything.
    3. I found an error regarding a firmware not being able to load. It was pointing to rtw88/rtw8822b_fw.bin

    My final step was to copy the lwfinger firmware I already had in /lib/firmware/rtlwifi/rtl8822befw.bin to the address pointed by the error. The I did a reboot and the error from the startup was gone, but I still couldnt find any networks. Installing wicd did the final trick and everything is working (although if someone has any info about how to fix it in network manager would be great, as I dont want to use wicd unless its necessary or I know what's the real difference).

    This, as you can see, is my first post, so I'm sorry if I'm missing any guidelines about proper formatting or whatever.

  6. #6
    Join Date
    2013-Apr
    Posts
    182
    I was backed to 4.19 , , copy the images 5.2.0 to another folder . and grub-mkconfig to generate the new grub .
    I found that , this problem not only happen in kali , but also in ubuntu which use linux kernel 5.2.0 . it
    couldnt find any networks.

  7. #7
    Join Date
    2019-Sep
    Posts
    2

    RTL8822BE Intermittent Issue

    Hi,

    I have had various issues with my wireless internal adapter Realtek RTL8822BE on my HP-X360 Laptop. I know it works because I have installed multiple distros and sometimes the drivers are there and it works and other times its not. I have had no luck getting the wifi drivers to work.

    So far I was able to get the wifi to show up by following this method

    You will need to install "make", "gcc", "kernel headers", "kernel build essentials", and "git".

    If you are running Ubuntu, then

    sudo apt-get install linux-headers-generic build-essential git

    Please note the first paragraph above.

    For all distros:
    git clone https://github.com/lwfinger/rtlwifi_new.git
    cd rtlwifi_new
    git checkout origin/extended -b extended
    sudo make install
    sudo modprobe -r rtl8822be


    depmod -a

    update-initramfs -u

    reboot



    After the reboot, the wifi shows up, but now it has no networks displayed. I also see that it states the network is down, but if I try bring it up (ip link set dev wlan0 up) it gives me a message

    root@hpx360:~# ip link set dev wlan0 up
    RTNETLINK answers: Operation not permitted

    The kernel used is 5.2.0-kali2-amd64.

    I have made some progress, but need a little extra help if anyone here can assist me with this matter I would greatly appreciate it.

    Thank you

  8. #8
    Join Date
    2017-Jun
    Posts
    3
    Quote Originally Posted by CaptainJoe View Post
    Hi,

    I have had various issues with my wireless internal adapter Realtek RTL8822BE on my HP-X360 Laptop. I know it works because I have installed multiple distros and sometimes the drivers are there and it works and other times its not. I have had no luck getting the wifi drivers to work.

    So far I was able to get the wifi to show up by following this method

    You will need to install "make", "gcc", "kernel headers", "kernel build essentials", and "git".

    If you are running Ubuntu, then

    sudo apt-get install linux-headers-generic build-essential git

    Please note the first paragraph above.

    For all distros:
    git clone https://github.com/lwfinger/rtlwifi_new.git
    cd rtlwifi_new
    git checkout origin/extended -b extended
    sudo make install
    sudo modprobe -r rtl8822be


    depmod -a

    update-initramfs -u

    reboot



    After the reboot, the wifi shows up, but now it has no networks displayed. I also see that it states the network is down, but if I try bring it up (ip link set dev wlan0 up) it gives me a message

    root@hpx360:~# ip link set dev wlan0 up
    RTNETLINK answers: Operation not permitted

    The kernel used is 5.2.0-kali2-amd64.

    I have made some progress, but need a little extra help if anyone here can assist me with this matter I would greatly appreciate it.

    Thank you
    Any updates? Did you finally fix it, If so, how?

  9. #9
    When I tried above steps it gives me error that "modprobe: FATAL: Module rtl8822be not found". I am also stuck at the same point and tried every possible solutions. Don't know what to do.

    Network controller: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter
    DeviceName: WLAN
    Subsystem: AzureWave RTL8822BE 802.11a/b/g/n/ac WiFi adapter
    Flags: fast devsel, IRQ 17
    I/O ports at 3000 [size=256]
    Memory at b1200000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: [40] Power Management version 3
    Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [148] Device Serial Number 00-e0-4c-ff-fe-b8-22-01
    Capabilities: [158] Latency Tolerance Reporting
    Capabilities: [160] L1 PM Substates
    Kernel modules: rtwpci

  10. #10
    Join Date
    2019-Oct
    Posts
    2
    I have same problem

    GNU bash, version 5.0.3(1)-release (x86_64-pc-linux-gnu)

    Anyone have news?

    Thanks in advanced

  11. #11
    Join Date
    2015-Mar
    Posts
    4
    Hello, it happened to me the same, after doing an upgrade to kernel 5.2, my RT3070 Wi-Fi adapter stopped working any advice from developers and users? Thank you.

  12. #12
    Join Date
    2015-Mar
    Posts
    4
    Friends this left me the adapter RT3070 Nisuta at 89% stable, the only problem is that in monitor mode it scans but does not see networks
    https://www.***********************QdCqABSQ-2Y

  13. #13
    Join Date
    2019-Nov
    Posts
    9
    I had the same problem once but different cause check NetworkManager file make sure it says =managed for your device not =unmanaged that's what my problem was. Hope it helps.

  14. #14
    Join Date
    2019-Nov
    Posts
    1
    I'm facing same problem, I installed rtl88be driver and before installing driver in "lshw -c network" command there was network unclaimed but after installing driver it's saying network disabled. and I can see my wifi option but it's saying device not ready. what does that mean ?

    sorry I'm new here and i don't know how to put command separately and all

  15. #15
    Join Date
    2019-Dec
    Posts
    1
    Hi
    After I adding the rtl8822befw.bin file to the directory, I executed this command in terminal.
    sudo apt-get install -d --reinstall network-manager network-manager-gnome

    By just executing above command, wifi manager shows all the available ssids and I could connect to my network as usual. I assume by reinstalling network manager it sets to it's default settings.

    Hope this will help.

  16. #16
    Join Date
    2019-Dec
    Posts
    5
    Quote Originally Posted by Joker007 View Post
    Hi
    After I adding the rtl8822befw.bin file to the directory, I executed this command in terminal.
    sudo apt-get install -d --reinstall network-manager network-manager-gnome

    By just executing above command, wifi manager shows all the available ssids and I could connect to my network as usual. I assume by reinstalling network manager it sets to it's default settings.

    Hope this will help.

    What is this befw.bin file?

    Where did you get it from and where exactly did you copy it to?

    Thanks mate

  17. #17
    Join Date
    2019-Dec
    Posts
    5


    Here?s how to solve the wifi problem:
    This is how it works on ParrotOS 4.7 with latest 5.3 kernel.
    This should also work for Kali Linux 2019.4 with latest kernel.

    I also managed to get the TX-power to 30db. I will post instructions later today.



    Ok, one way to get it running is this:


    From clean ParrotOS 4.7 with all updates loaded:

    1. go to /lib/firmware/
    2. here you will need to create a folder named rtw88
    3. go to /lib/firmware/rtlwifi/
    4. here you will need to copy the file rtl8822befw.bin
    5. go to /lib/firmware/rtw88/
    6. here you will need to insert the file you just copied (rtl8822befw.bin)
    7. now you will need to rename the file to rtw8822b_fw.bin
    8. reboot your system

    Now your network manager should be able use your rtl8822be wifi adapter without any problems.


    Right now my ParrotOS has two bluetooth symbols in the task line but wifi is working.

    Now I will try to correct the bluetooth.


    I?ll let keep you up to date.



    veo



  18. #18
    Join Date
    2019-Dec
    Posts
    5
    Here?s how to solve the wifi problem with latest 5.3 kernels:


    rtl8822be also supports fully working monitor mode now!


    I also managed to get the TX-power to 30db. I will post instructions later today.


    Ok, one way to get it running is this:


    From clean ParrotOS 4.7 with all updates + latest kernel 5.3 loaded:
    Should also work with Kali Linux 2019.4 + latest 5.3 kernel loaded:



    1. go to /lib/firmware/
    2. here you will need to create a folder named rtw88
    3. go to /lib/firmware/rtlwifi/
    4. here you will need to copy the file rtl8822befw.bin
    5. go to /lib/firmware/rtw88/
    6. here you will need to insert the file you just copied (rtl8822befw.bin)
    7. now you will need to rename the file to rtw8822b_fw.bin
    8. reboot your system


    Now your network manager should be able use your rtl8822be wifi adapter without any problems.
    I just managed this to work.

    Right now my ParrotOS has two bluetooth symbols in the task line but wifi is working. Now I will try to correct the bluetooth.

    I?ll let keep you up to date.


    Alright, bluetooth problem seems to be solved by just rebooting twice.
    After two reboots my ParrotOS only shows one bluetooth symbol in the task line.


    You might need to turn bluetooth on and off before or after rebooting to get rid of the second bluetooth symbol.
    I actually played around with on and off a little bit and then just rebooted again.


    Now the bluetooth seems to work and only shows up once.


    TX-power adjustment How-To will follow later on today.
    veo

  19. #19
    Join Date
    2013-Apr
    Posts
    182
    tried all above methods , but all not workable for me . Are there any method can workable for me ?

  20. #20
    Join Date
    2013-Apr
    Posts
    182
    solved. finally worked ,
    Linux ubt 5.4.0-kali3-amd64 #1 SMP Debian 5.4.13-1kali1 (2020-01-20) x86_64 GNU/Linux

    please check this links
    https://aur.archlinux.org/packages/r...extended-dkms/
    https://github.com/lwfinger/rtlwifi_new

  21. #21
    Quote Originally Posted by when123 View Post
    tried all above methods , but all not workable for me . Are there any method can workable for me ?
    GUYS I DO NOT GET YOUR PROBLEM,

    I WROTE YOU 2 TIMES IN 2 DIFFERENT COLORS HOW IT WORKS WITHIN 2 MINUTES xD

    I just tried this method myself again on Kali 2020.1 and it works perfectly.

    Read my post carefully and do exactly what I tell you and you will be happy with your realtek rtl8822be.

    If you are using Kali 2020.1 you will have to do these steps in terminal (create folder, copy file, rename file). I will not tell you the terminal commands for doing this in terminal now.

    Just google and the job is done.

  22. #22
    Join Date
    2016-Oct
    Location
    London
    Posts
    46
    Quote Originally Posted by Steve Ocean View Post
    Here?s how to solve the wifi problem with latest 5.3 kernels:


    rtl8822be also supports fully working monitor mode now!


    I also managed to get the TX-power to 30db. I will post instructions later today.


    Ok, one way to get it running is this:


    From clean ParrotOS 4.7 with all updates + latest kernel 5.3 loaded:
    Should also work with Kali Linux 2019.4 + latest 5.3 kernel loaded:



    1. go to /lib/firmware/
    2. here you will need to create a folder named rtw88
    3. go to /lib/firmware/rtlwifi/
    4. here you will need to copy the file rtl8822befw.bin
    5. go to /lib/firmware/rtw88/
    6. here you will need to insert the file you just copied (rtl8822befw.bin)
    7. now you will need to rename the file to rtw8822b_fw.bin
    8. reboot your system


    Now your network manager should be able use your rtl8822be wifi adapter without any problems.
    I just managed this to work.

    Right now my ParrotOS has two bluetooth symbols in the task line but wifi is working. Now I will try to correct the bluetooth.

    I?ll let keep you up to date.


    Alright, bluetooth problem seems to be solved by just rebooting twice.
    After two reboots my ParrotOS only shows one bluetooth symbol in the task line.


    You might need to turn bluetooth on and off before or after rebooting to get rid of the second bluetooth symbol.
    I actually played around with on and off a little bit and then just rebooted again.


    Now the bluetooth seems to work and only shows up once.


    TX-power adjustment How-To will follow later on today.
    [COLOsR=#ff0000]veo[/COLOR]
    This method worked till the last kali update but the latest one not detecting any network now.
    Is there any proper solution for this? Why this driver is not included in kali linux?

  23. #23
    Join Date
    2016-Oct
    Location
    London
    Posts
    46
    this is the working solution.
    git clone https://github.com/lwfinger/rtlwifi_new.git
    cd rtlwifi_new
    git checkout extended
    make
    sudo make install
    sudo modprobe -r rtl8822
    sudo modprobe rtl8822


    At this point, do a complete shutdown! The device may retain the old setting with a warm reboot.
    To be safe, do a power off.
    After the system come back up, your WiFi and Bluetooth working now.

  24. #24
    Join Date
    2020-May
    Posts
    1

    Network Activation Failed

    Quote Originally Posted by Thiviyan View Post
    this is the working solution.
    git clone https://github.com/lwfinger/rtlwifi_new.git
    cd rtlwifi_new
    git checkout extended
    make
    sudo make install
    sudo modprobe -r rtl8822
    sudo modprobe rtl8822


    At this point, do a complete shutdown! The device may retain the old setting with a warm reboot.
    To be safe, do a power off.
    After the system come back up, your WiFi and Bluetooth working now.
    I did this, after the system came back The pc is connected to the internet for a few seconds and then I get a system pop up saying Network Activation failed.

    Any ideas why is this happening?

  25. #25
    Join Date
    2020-May
    Posts
    1
    My thinkpad t470 with newest kali 2020.2 also get this problem. But this not solved. It still not have WIFI on Kali.

    Quote Originally Posted by Thiviyan View Post
    this is the working solution.
    git clone https://github.com/lwfinger/rtlwifi_new.git
    cd rtlwifi_new
    git checkout extended
    make
    sudo make install
    sudo modprobe -r rtl8822
    sudo modprobe rtl8822


    At this point, do a complete shutdown! The device may retain the old setting with a warm reboot.
    To be safe, do a power off.
    After the system come back up, your WiFi and Bluetooth working now.

  26. #26
    Join Date
    2016-Oct
    Location
    London
    Posts
    46
    i had problems with the latest kali update and i got my WiFi working after doing this.
    for this you will need internet so just connect an external WiFi adapter or use Ethernet connection to fix this issue
    git clone https://github.com/lwfinger/rtlwifi_new.git -b rtw88
    cd rtlwifi_new
    make
    sudo make install
    sudo modprobe -r rtw_8822be
    sudo modprobe rtw_8822be

    do a complete shutdown and turn on (not just restart) this will get your WiFi back

  27. #27
    Join Date
    2020-May
    Posts
    2
    When I updated kali I also had problems connecting to the internet so I go to the
    1 - / etc / network /
    2 - open the file "interfaces"
    3 - type the following:
    auto eth0
    iface eth0 inet dhcp

    4 - reboot the system

    and everything is working fine now.

  28. #28
    Join Date
    2020-May
    Location
    Cambodia
    Posts
    2
    Hi mate, does RTL8822BE support airepaly-ng injection?
    Your driver working fine and fast responded from Internet, but aireplay-ng --test <interface> still failed(no answers).

    kali@kali:~$ sudo aireplay-ng --test wlan0
    [sudo] password for kali:
    ioctl(SIOCSIWMODE) failed: Device or resource busy
    22:56:39 Trying broadcast probe requests...
    22:56:41 No Answer...
    22:56:41 Found 2 APs


    22:56:41 Trying directed probe requests...
    22:56:41 XX:XX:XX:XX:XX:XX - channel: 2 - 'Try'
    22:56:47 0/30: 0%


    22:56:47 XX:XX:XX:XX:XX - channel: 2 - 'Test'
    22:56:53 0/30: 0%

  29. #29
    Join Date
    2016-Oct
    Location
    London
    Posts
    46
    RTL8822BE dose not work out of the box. i am always facing issues whenever i upgrade my kernel. rtlwifi by lwfinger is the only driver gets constant updates but ye injections dont work...

  30. #30
    Join Date
    2020-May
    Location
    Cambodia
    Posts
    2

    Quote Originally Posted by Thiviyan View Post
    RTL8822BE dose not work out of the box. i am always facing issues whenever i upgrade my kernel. rtlwifi by lwfinger is the only driver gets constant updates but ye injections dont work...
    Thanks you!

  31. #31
    Join Date
    2020-Jun
    Posts
    5
    How to increase TX-POWER to 30dbm and my wifi card's also changes everytime i insert it

  32. #32
    Join Date
    2020-Jun
    Posts
    1
    Does anyone know how I would build this into a live-usb without using persistence. The slowdown is really annoying to deal with and I have just been rebuilding it often to limit it.

  33. #33
    Join Date
    2019-Sep
    Posts
    2
    Dear Steve Ocean,

    Thank you so much a method that finally works. I had a little laugh earlier because I found a person in here who had the exact same computer and problem I had, only to realize it was actually me who wrote it HAHA.When I came across your instructions, it seemed different to what I had read before, and you stated it worked so I thought I would give it a try. I also like that you detailed the steps in a clear, easy to read manner.

    I wanted to try the new updated copy of Kali-Linux again because I recently graduated with my Bachelors in IT and Cybersecurity so I wanted to refresh myself on the tools available again, and believe or not the wifi was not showing up. I remember having this problem on multiple distro's. I have yet to find a solution that works, until I came across your post.

    I just wanted to reply to everyone else here that your method works. I didn't see an issue with the Bluetooth as you had stated there were 2 instances.

    Anyway, take care and thank you for this. I really appreciate.

Similar Threads

  1. Is there an updated list of supported wifi dongle / wlan1 for NH3 ?
    By happymood in forum NetHunter General Questions
    Replies: 3
    Last Post: 2016-05-09, 09:20
  2. Getting kernel 4.4 working in Kali
    By Factionite in forum General Archive
    Replies: 0
    Last Post: 2016-01-21, 01:34
  3. Replies: 5
    Last Post: 2015-10-02, 01:56
  4. guest additions not working with kernel 3.18 installed
    By SimbaClaws in forum Installing Archive
    Replies: 3
    Last Post: 2015-04-24, 03:26
  5. Replies: 2
    Last Post: 2014-08-01, 07:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •