Results 1 to 5 of 5

Thread: When comes the Support of gr-gsm for gnuradio 3.8?

  1. #1
    Join Date
    2019-Aug
    Posts
    13

    When comes the Support of gr-gsm for gnuradio 3.8?

    Hi there,
    i can't compile gr-gsm with the new Version of Gnuradio?
    If i type



    ~/gr-gsm/build# cmake ..
    -- The CXX compiler identification is GNU 9.2.1
    -- The C compiler identification is GNU 9.2.1
    -- Check for working CXX compiler: /usr/bin/c++
    -- Check for working CXX compiler: /usr/bin/c++ -- works
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    -- Detecting CXX compile features
    -- Detecting CXX compile features - done
    -- Check for working C compiler: /usr/bin/cc
    -- Check for working C compiler: /usr/bin/cc -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Detecting C compile features
    -- Detecting C compile features - done
    -- Build type not specified: defaulting to release.
    CMake Deprecation Warning at CMakeLists.txt:45 (cmake_policy):
    The OLD behavior for policy CMP0026 will be removed from a future version
    of CMake.

    The cmake-policies(7) manual explains that the OLD behaviors of all
    policies are deprecated and that a policy should be set to OLD only under
    specific short-term circumstances. Projects should be ported to the NEW
    behavior and not rely on setting a policy to OLD.


    CMake Deprecation Warning at CMakeLists.txt:48 (cmake_policy):
    The OLD behavior for policy CMP0043 will be removed from a future version
    of CMake.

    The cmake-policies(7) manual explains that the OLD behaviors of all
    policies are deprecated and that a policy should be set to OLD only under
    specific short-term circumstances. Projects should be ported to the NEW
    behavior and not rely on setting a policy to OLD.


    CMake Deprecation Warning at CMakeLists.txt:51 (cmake_policy):
    The OLD behavior for policy CMP0045 will be removed from a future version
    of CMake.

    The cmake-policies(7) manual explains that the OLD behaviors of all
    policies are deprecated and that a policy should be set to OLD only under
    specific short-term circumstances. Projects should be ported to the NEW
    behavior and not rely on setting a policy to OLD.


    CMake Deprecation Warning at CMakeLists.txt:54 (cmake_policy):
    The OLD behavior for policy CMP0046 will be removed from a future version
    of CMake.

    The cmake-policies(7) manual explains that the OLD behaviors of all
    policies are deprecated and that a policy should be set to OLD only under
    specific short-term circumstances. Projects should be ported to the NEW
    behavior and not rely on setting a policy to OLD.


    -- Found Git: /usr/bin/git (found version "2.23.0.rc1")
    -- Extracting version information from git describe...
    -- Looking for pthread.h
    -- Looking for pthread.h - found
    -- Looking for pthread_create
    -- Looking for pthread_create - not found
    -- Looking for pthread_create in pthreads
    -- Looking for pthread_create in pthreads - not found
    -- Looking for pthread_create in pthread
    -- Looking for pthread_create in pthread - found
    -- Found Threads: TRUE
    -- Boost version: 1.67.0
    -- Found the following Boost libraries:
    -- filesystem
    -- system
    -- thread
    -- chrono
    -- date_time
    -- atomic
    --
    -- Checking for module SWIG
    -- Found SWIG version 3.0.12.
    -- Found SWIG: /usr/bin/swig3.0
    -- Found LOG4CPP: /usr/lib/x86_64-linux-gnu/liblog4cpp.so
    -- Found PkgConfig: /usr/bin/pkg-config (found version "0.29")
    -- Checking for module 'gmp'
    -- No package 'gmp' found
    -- Found GMP: /usr/lib/x86_64-linux-gnu/libgmpxx.so
    -- Checking for module 'mpir >= 3.0'
    -- No package 'mpir' found
    -- Could NOT find MPIR (missing: MPIRXX_LIBRARY MPIR_LIBRARY MPIR_INCLUDE_DIR)
    -- Found MPLIB: /usr/lib/x86_64-linux-gnu/libgmpxx.so
    -- Checking for module 'volk'
    -- Found volk, version 2.0
    -- Found VOLK: /usr/lib/x86_64-linux-gnu/libvolk.so
    CMake Warning at CMakeLists.txt:135 (find_package):
    Found package configuration file:

    /usr/lib/x86_64-linux-gnu/cmake/gnuradio/GnuradioConfig.cmake

    but it set Gnuradio_FOUND to FALSE so package "Gnuradio" is considered to
    be NOT FOUND. Reason given by package:

    Gnuradio could not be found because dependency Volk could not be found.



    -- Checking for module 'cppunit'
    -- Found cppunit, version 1.14.0
    -- Found CPPUNIT: /usr/lib/x86_64-linux-gnu/libcppunit.so;dl
    -- Checking for module 'libosmocore'
    -- Found libosmocore, version 0.12.0
    -- Found libosmocore: /usr/lib/x86_64-linux-gnu/libosmocore.so
    -- Checking for module 'libosmocodec'
    -- Found libosmocodec, version 0.12.0
    -- Found libosmocodec: /usr/lib/x86_64-linux-gnu/libosmocodec.so
    -- Checking for module 'libosmocoding'
    -- Found libosmocoding, version 0.12.0
    -- Found libosmocoding: /usr/lib/x86_64-linux-gnu/libosmocoding.so
    -- Checking for module 'libosmogsm'
    -- Found libosmogsm, version 0.12.0
    -- Found libosmogsm: /usr/lib/x86_64-linux-gnu/libosmogsm.so
    CMake Error at CMakeLists.txt:150 (message):
    GnuRadio Runtime required to compile gr-gsm


    -- Configuring incomplete, errors occurred!
    See also "/root/gr-gsm/build/CMakeFiles/CMakeOutput.log".
    See also "/root/gr-gsm/build/CMakeFiles/CMakeError.log".


    What can i do now to compile it in Kali? Or is it the Support that fails?
    Thanks in advance!
    msfu

  2. #2
    Join Date
    2016-Dec
    Posts
    706
    The first step in an issue is to read the messages carefully. Two files were created, as you show in the ouput:

    See also "/root/gr-gsm/build/CMakeFiles/CMakeOutput.log".
    See also "/root/gr-gsm/build/CMakeFiles/CMakeError.log".
    The second thing, after looking at these file is to look in google (or Yahoo, or any other search engine of your choice) for solutions, and remember that Kali is based on Debian (testing), that will help expand the results.

    The third thing is to describe the issue accurately:
    1. What have you done? Different commands and their respective outputs. Like what repo did you clone, what packages did you install? What make/configure/autoconfig commands did you run? And so on.
    2. What are the results?
    3. What were you expecting?
    4. Give any relevant details on the different parts, and show that you've done thorough research before posting.

  3. #3
    Join Date
    2019-Aug
    Posts
    13
    Thanks for your Answer!

    I installed gnuradio and gqrx via apt and both tools are working.

    We discussed this Problem here before i wrote in this Forum but the Answers were not statisfactory. Because i don't want to downgrade gnuradio and i don't want to use Docker... https://github.com/ptrkrysik/gr-gsm/issues/476

    I don't know why but today cmake .. works, but now i have an error by the make command...

    I cloned the repo from here

    https://osmocom.org/projects/gr-gsm/wiki/Installation

    and did the following:


    sudo apt-get update && \
    sudo apt-get install -y \
    cmake \
    autoconf \
    libtool \
    pkg-config \
    build-essential \
    python-docutils \
    libcppunit-dev \
    swig \
    doxygen \
    liblog4cpp5-dev \
    python-scipy \
    python-gtk2 \
    gnuradio-dev \
    gr-osmosdr \
    libosmocore-dev

    Then i cloned the repo with this commands:



    git clone https://git.osmocom.org/gr-gsm
    cd gr-gsm
    mkdir build
    cd build
    cmake ..
    mkdir $HOME/.grc_gnuradio/ $HOME/.gnuradio/


    but if i do the make command it gaves me this Output:


    ~/gr-gsm/build# make
    Scanning dependencies of target grgsm
    [ 1%] Building CXX object lib/CMakeFiles/grgsm.dir/constants.cc.o
    [ 2%] Linking CXX shared library libgrgsm-0.42.2..so
    [ 62%] Built target grgsm
    [ 62%] Built target grgsm_swig_swig_doc
    [ 64%] Built target _grgsm_swig_swig_tag
    Scanning dependencies of target grgsm_swig_swig_2d0df
    [ 65%] Building CXX object swig/CMakeFiles/grgsm_swig_swig_2d0df.dir/grgsm_swig_swig_2d0df.cpp.o
    [ 67%] Linking CXX executable grgsm_swig_swig_2d0df
    Swig source
    [ 68%] Built target grgsm_swig_swig_2d0df
    [ 69%] Generating grgsm_swig.pyc
    [ 70%] Generating grgsm_swig.pyo
    [ 71%] Built target pygen_swig_73903
    Scanning dependencies of target _grgsm_swig
    [ 72%] Building CXX object swig/CMakeFiles/_grgsm_swig.dir/grgsm_swigPYTHON_wrap.cxx.o
    [ 73%] Linking CXX shared module _grgsm_swig.so
    [ 75%] Built target _grgsm_swig
    [ 78%] Built target pygen_python_cd01a
    [ 80%] Built target pygen_python_misc_utils_b99a1
    [ 82%] Built target pygen_python_receiver_5d841
    [ 84%] Built target pygen_python_demapping_2c442
    [ 86%] Built target pygen_python_transmitter_29c4b
    [ 89%] Built target pygen_python_trx_86bb3
    [ 90%] Generating grgsm_livemon
    Traceback (most recent call last):
    File "/root/gnuradio/bin/grcc", line 29, in <module>
    from gnuradio import gr
    ImportError: No module named gnuradio
    make[2]: *** [apps/CMakeFiles/pygen_apps.dir/build.make:85: apps/grgsm_livemon] Error 1
    make[1]: *** [CMakeFiles/Makefile2:1323: apps/CMakeFiles/pygen_apps.dir/all] Error 2
    make: *** [Makefile:141: all] Error 2



    I did everything like provided on the osmocom page, but still i doesn't get gr-gsm complete compiled. Have you got a recommendation?

  4. #4
    Join Date
    2019-Aug
    Posts
    13
    I'm sorry, but i can't post the Output of


    /root/gr-gsm/build/CMakeFiles/CMakeOutput.log

    and

    /root/gr-gsm/build/CMakeFiles/CMakeError.log

    because of your Firewall. I don't know why...

  5. #5
    Join Date
    2016-Dec
    Posts
    706
    Sounds like you need a python module named gnuradio. Unless that is a bug in their stuff.

Similar Threads

  1. GNURADIO errors
    By j4mbob in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2017-12-22, 10:33
  2. Kali 1.1.0 and Gnuradio
    By fe8769 in forum General Archive
    Replies: 4
    Last Post: 2015-07-25, 19:16
  3. How to upgrade gnuradio?
    By Toontje in forum General Archive
    Replies: 2
    Last Post: 2015-07-20, 13:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •