Results 1 to 17 of 17

Thread: 2019.3 Upgrade or Install from USB - Whitebox over desktop wallpaper / Menu items

  1. #1
    Join Date
    2019-Sep
    Posts
    2

    Unhappy 2019.3 Upgrade or Install from USB - Whitebox over desktop wallpaper / Menu items

    I had a dual-boot Mac/Kali. When I updated from 2019.2 to 2019.3 I got a white box covering the background image. The white background/whatever this is also persisted for the menu drop-downs for both [Applications] and the [Top-Right Arrow]. If I clicked the [Top-Right Arrow] multiple times the white would go back to normal dark-grey for the drop-list. This trick does not work for the [Applications] menu and the white bleeds out the white text list. I tried fixing this by reinstalling the GRUB loader but I ended up hosing my Mac boot ability.

    This morning I reinstalled Kali using 2019.3 and decided to go full disk install (no more dual-boot) which I am cool with and do not need to go back to this, at least at this time. However the same white box is persisting. I can get rid of the white box over desktop background by changing it to a solid color. However the white persists for the drop-menus. I thought this was a video driver issue at first but I do not think it is at all. I can open and run programs just fine. It is just this freakish white box that appears when any desktop background image is selected. (Tried selecting other desktop background images and the white box persists). In screenshots below you can see where the white box ends nearly 1/2" from bottom of screen so its not quite 100% fill.

    Additionally, When the screen locks out I am unable to use mousepad to swipe up to open login option to get back into system.

    My Hardware is a mid 2015 MacBook Pro. No longer any dual-boot (due to trouble-shooting the issue) and is now straight 100% Kali.

    5.jpg4.jpg3.jpg1.jpg2.jpg

    Please help.

  2. #2
    Join Date
    2019-Sep
    Posts
    2
    Update, I reinstalled with Kali 2019.2 and I do not have this issue. Tried updating/upgrading to the 2019.3 version and the issue comes back. Reinstalled 2019.2 and the white box issue is not there. I do not know if this is an issue with other computers but it is with my Macbook Pro mid-2015. Hope this helps. I am sure I am not the only one experiencing this problem. Love Kali and what you offer!

  3. #3
    Join Date
    2017-Jul
    Posts
    6
    I have exactly the same issue! Is this a known bug?

  4. #4
    Join Date
    2017-Jul
    Posts
    6
    Is there a way to downgrade the xorg system? Any other suggestions to debug this problem? Tnx

  5. #5
    Join Date
    2019-Dec
    Posts
    4
    I also have this exact same issue on a fresh install of Kali 2019.4 on a 2016 Mac Book Pro. The background of the desktop is all white except for the bottom inch of the screen where I can see the bottom of the background image. When I open a browser and scroll, it appears that a white box covers the majority of the browser. When I stop scrolling I can sometimes see all the content in the browser. When I click off the browser to another application, the browser white box covers some of the content again.

    I am not dual booting and I am using encryption LVM with home, var and tmp in different partitions.

    Radeon HD 8870 / R9 M270X/M370X
    Subsystem Apple Inc. Radeon R9 M370X Mac Edition
    Kernel driver in use: radeon
    Kernel modules: radeon, amdgpu


    If anyone has any information to overcome this it would be greatly appreciated.

  6. #6
    Join Date
    2019-Dec
    Posts
    4
    I am dealing with this same issue on -

    Mac Book Pro 2016
    Full disk install, full disk encryption, LVM
    Kali 2019.4
    GPU - AMD/ATI Venus XT [Radeon HD 8870M / R9 M270X/M370

    Any help would be greatly appreciated. I have reinstalled trying KDE and Gnome. Both have the same issue.

  7. #7
    Join Date
    2019-Dec
    Posts
    4
    I am dealing with this same issue on -

    Mac Book Pro 2016
    Full disk install, full disk encryption, LVM
    Kali 2019.4
    GPU - AMD/ATI Venus XT [Radeon HD 8870M / R9 M270X/M370

    Any help would be greatly appreciated. I have reinstalled trying KDE and Gnome. Both have the same issue.

  8. #8
    Join Date
    2019-Dec
    Posts
    2
    Same issue here ...

    Mac Book Pro 2016
    Radeon M370X
    Kali 2019.4

  9. #9
    Join Date
    2019-Dec
    Posts
    1
    It seems the problem is the incomplete optimization with mac display. It is fixable though. You just have to lower your kali resolution with settings->display

  10. #10
    Join Date
    2019-Dec
    Posts
    4
    Thanks @GaZZ, I went through each resolution all the way down to 800 X 600 till it worked.

    I can confirm that 800 X 600 on a 2015 Mac Book Pro works. Each applications is now working without the white overlay blocking the content.

    Funny thing is I went out and bought a new Dell XPS 7590 after giving up on fixing this issue with the Mac Book Pro...

  11. #11
    Join Date
    2020-Jan
    Posts
    1
    hello,
    I've had similar issues with that and learned the fastest way to correct it is, lower resolution, then select desktop background, select wallpaper again, then back out and refresh screen. Alot of times it happens with VM ware due to memory/resolution issues. hope this helps.

  12. #12
    Join Date
    2016-May
    Posts
    2
    Same issue here. I have a MacBook Pro mid2015, I just did a dual boot again with the latest Kali and this happens. I tried several releases, the last working one is 2019.2.

    2019.3 and 2019.4 both have this issue, either with Gnome or XFCE. Rebooting, changing the background etc won't help. Changing the resolution to 800x600 does, but seriously, who can work with that?

    I believe it has to do with some firmware change for the AMD Graphics card (I have a Radeon M370X), but can't know for sure. There were some firmware files missing under /lib/firmware/amdgpu/, but even replacing them from the linux-firmware git branch of Debian didn't help.

    How to troubleshoot this?

  13. #13
    Join Date
    2017-Jul
    Posts
    6
    Installed latest version today... issue still persists. This issue is sooooooo annoying!

  14. #14
    Join Date
    2016-Jul
    Posts
    15
    Yes, same issue. Dual boot, MacBook Pro. (2020.2)

  15. #15
    Join Date
    2017-Jul
    Posts
    6
    *BUMP*

  16. #16
    Join Date
    2018-May
    Posts
    43
    I had the same thing, hated the white. Dumped it and went back to the early version.

  17. #17
    You must have chose a wrong one that i presume to be the "Kali Linux 64-Bit (Installer)". You needed to boot this one "Kali Linux 64-Bit (Live)". Sometimes when you are in haste your mind doesn't support much.

Similar Threads

  1. Can't drag icons from menu to desktop in Kali 2019.1 among other things
    By buttmunch in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2019-03-06, 21:50
  2. Edit or add new menu items in kali 2.0
    By ShatStank in forum General Archive
    Replies: 13
    Last Post: 2017-06-17, 04:07
  3. Remove desktop items (and other insight)
    By jp400motox in forum General Archive
    Replies: 3
    Last Post: 2016-07-14, 05:18
  4. Adding menu items to your custom ISO image
    By jackal713 in forum How-To Archive
    Replies: 0
    Last Post: 2014-03-10, 19:37
  5. Running menu items as su
    By Cyaegha in forum General Archive
    Replies: 1
    Last Post: 2013-08-11, 16:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •