Results 1 to 10 of 10

Thread: Kali, VirtualBox, AWUS1900: no wifi connection

  1. #1
    Join Date
    2019-Sep
    Posts
    6

    Kali, VirtualBox, AWUS1900: no wifi connection

    BASIC SITUATION


    • My host system is Windows 10.
    • My AWUS1900 works in Windows 10. I can see (many) nearby wireless APs broadcasting their existence, and I can connect to those I manage. The wifi unit works.
    • In VirtualBox I am running Kali. VirtualBox does capture the AWUS1900. Kali does show a wlan0 adapter.
    • But within Kali I am not seeing any APs at all. Kali finds nothing for the wifi to connect to.


    More specifically, when I followed the installation instructions at https://online-it.nu/how-to-install-...-linux-2018-4/ everything appeared to work up to the point where I launched airodump-ng wlan0 to sniff the network. Airodump-ng finds no networks. Similarly if I click the network icon at the top right of my Kali installation (I have the XFCE UI) I see "Wi-Fi Networks" followed by "disconnected" and no list of available networks. Running airmon-ng check kill made no difference to this behavior.

    I've found a number of helpful pages around the web for getting Alfa USB units to work in a Kali VM, but none of the pages I found described this particular problem.

    I am still relatively new to Linux. I could well be making beginner mistakes.



    DETAILS

    VirtualBox 6.0.10 r132072
    This VM is configured for USB 3.0.

    > lsb_release -a
    No LSB modules are available.
    Distributor ID: Kali
    Description: Kali GNU/Linux Rolling
    Release: 2019.4
    Codename: kali-rolling

    > uname -a
    Linux KaliVM 5.2.0-kali2-amd64 #1 SMP Debian 5.2.9-2kali1 (2019-08-22) x86_64 GNU/Linux

    > lsusb
    Bus 001 Device 003: ID 0bda:8813 Realtek Semiconductor Corp. RTL8814AU 802.11a/b/g/n/ac Wireless Adapter
    (and some others)

    > iwconfig
    eth0 no wireless extensions.

    lo no wireless extensions.

    wlan0 IEEE 802.11 ESSIDff/any
    Mode:Managed Access Point: Not-Associated Tx-Power=18 dBm
    Retry short limit:7 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff

    > airmon-ng --verbose

    No LSB modules are available.
    Distributor ID: Kali
    Description: Kali GNU/Linux Rolling
    Release: 2019.4
    Codename: kali-rolling

    Linux KaliVM 5.2.0-kali2-amd64 #1 SMP Debian 5.2.9-2kali1 (2019-08-22) x86_64 GNU/Linux
    Detected VM using lspci
    This appears to be a VirtualBox Virtual Machine
    If your system supports VT-d, it may be possible to use PCI devices
    If your system does not support VT-d, you can only use USB wifi cards

    K indicates driver is from 5.2.0-kali2-amd64
    V indicates driver comes directly from the vendor, almost certainly a bad thing
    S indicates driver comes from the staging tree, these drivers are meant for reference not actual use, BEWARE
    ? indicates we do not know where the driver comes from... report this


    X[PHY]Interface Driver[Stack]-FirmwareRev Chipset Extended Info

    ?[phy0]wlan0 88XXau[mac80211]-unavailable Realtek Semiconductor Corp. RTL8814AU 802.11a/b/g/n/ac mode managed

  2. #2
    Join Date
    2016-Dec
    Location
    Canada
    Posts
    282
    ifconfig wlan0 up

    also check
    rfkill list all
    But that might not work since your not getting any errors

  3. #3
    Join Date
    2016-Dec
    Posts
    674
    Just FYI: A driver on linux are entirely different than the ones on Windows, in terms of features and in terms of code as well.

    However, VirtualBox USB passthrough driver has bugs and drops packets, so it may be due to that.

    Two things:
    - try to switch from USB 2.0 to 3.0 and vice versa
    - Look into dmesg, if there are issues with the driver, they'll be there.

    Regarding airodump-ng, how did you put the card in monitor mode? Did you kill the network managers BEFORE putting the card in monitor mode? What is the exact airodump-ng command you ran?

  4. #4
    Join Date
    2019-Sep
    Posts
    6
    Thank you for your response.

    > Just FYI: A driver on linux are entirely different than the ones on Windows, in terms of features and in terms of code as well.

    Yes, I do get that. I only mentioned what happens in Windows as evidence that there are lots of APs active around me. They should be showing up in Kali too. And the card itself does work. It doesn't appear to be a hardware problem.

    > try to switch from USB 2.0 to 3.0 and vice versa

    I did try that. It didn't help.

    > Look into dmesg, if there are issues with the driver, they'll be there.

    This looks like it might be the relevant section from dmesg:

    [ 3.027002] usb 1-2: new high-speed USB device number 3 using xhci_hcd
    [ 3.368783] usb 1-2: New USB device found, idVendor=0bda, idProduct=8813, bcdDevice= 0.00
    [ 3.368789] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 3.368793] usb 1-2: Product: 802.11ac NIC
    [ 3.368796] usb 1-2: Manufacturer: Realtek
    [ 3.368799] usb 1-2: SerialNumber: 123456

    > Regarding airodump-ng, how did you put the card in monitor mode? Did you kill the network managers BEFORE putting the card in monitor mode? What is the exact airodump-ng command you ran?[/QUOTE]

    These are the commands I used to put the card in monitor mode:

    sudo ip link set wlan0 down
    sudo iwconfig wlan0 mode monitor
    sudo ip link set wlan0 up

    And this is my airodump command.


    airodump-ng wlan0

  5. #5
    Join Date
    2019-Sep
    Posts
    6
    Thank you. I appreciate the help.

    > ifconfig wlan0 up

    Yes. I also use ip link set wlan0 up.

    > Also check rfkill list all

    sudo rfkill list all
    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

  6. #6
    Join Date
    2019-Sep
    Posts
    6
    Possibly this screenshot may clarify my earlier description of what the Kali UI is showing me. The USB wifi card is present but apparently unable to locate or connect to APs.

    VirtualBox_Kali_09_09_2019_20_59_43.jpg

  7. #7
    Join Date
    2016-Dec
    Posts
    674
    You forgot to kill network managers that can interfere with capture. Do that before putting the card in monitor mode, ALWAYS.

    airmon-ng check kill
    airmon-ng start wlan0
    airodump-ng wlan0mon

  8. #8
    Join Date
    2019-Sep
    Posts
    6
    Thanks for keeping with me Mister_X. I tried these commands but they didn't seem to help:

    # airmon-ng check kill

    Killing these processes:

    PID Name
    1301 wpa_supplicant

    # airmon-ng start wlan0
    PHY Interface Driver Chipset
    phy0 wlan0 88XXau Realtek Semiconductor Corp. RTL8814AU 802.11a/b/g/n/ac
    (monitor mode enabled)

    # airodump-ng wlan0mon
    Interface wlan0mon:
    ioctl(SIOCGIFINDEX) failed: No such device
    Failed initializing wireless card(s): wlan0mon

    # airodump-ng wlan0

    CH 4 ][ Elapsed: 1 min ][ 2019-09-13 21:43

    BSSID PWR Beacons #Data, #/s CH MB ENC CIPHER AUTH ESSID


    BSSID STATION PWR Rate Lost Frames Probe

  9. #9
    Join Date
    2016-Dec
    Posts
    674
    Before you run airmon-ng, clear dmesg (dmesg -c), then run airmon-ng, then airodump-ng, and see what's in dmesg.

  10. #10
    Join Date
    2019-Sep
    Posts
    6
    I am grateful for your continued help. I ran dmesg -c, airmon-ng, and then airdump-ng. Running dmesg after that produced nothing:

    # dmesg
    #

Similar Threads

  1. EXTREME WIFI SUPPORT: Alfa Networks AWUS1900 -- WORKING
    By kimocoder in forum How-To Archive
    Replies: 21
    Last Post: 2019-02-23, 11:07
  2. Replies: 1
    Last Post: 2017-12-19, 05:08
  3. PPTP VPN connection issues in a kali virtual machine (virtualbox)
    By sirtadels in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-04-05, 18:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •