Results 1 to 3 of 3

Thread: Kali light 32-bit 2019.3 grub install failure

  1. #1

    Exclamation Kali light 32-bit 2019.3 grub install failure

    The image was downloaded, verified and mounted on a 32GB USB key today (21/09/2019).
    The laptop was previously using Kali 64-bit (I had been under the impression that the architecture was amd64, when it was actually i386)
    The previous install worked just fine, but I wanted to try out the light version.

    Installation went more or less as follows:
    First, the network wireless configuration fails to exchange keys (Tried 3 times. The network and password were correct, I am currently using the same network via live boot to post this)
    I skipped network configuration.
    Everything then went on fine, until grub failed to install.
    I was able to check the log, "grub-efi-amd64" was being called, but was missing.
    A bit higher in the log, it was stated that "grub-efi-amd64" couldn't be installed, but that it had replacement files, including "grub-efi-ia32".
    Correct me if I'm wrong, but it seems to me that a 32-bit install shouldn't be calling an amd64?
    CTRL+ALT+F2 and CTRL+ALT+F3 did nothing (documentation states that they should open a shell).
    According to some, the grub issue can be fixed by either:
    1. Turning off mirror, which I tried.
    2. Configuring the network to allow the installer to download missing packages, which does not work for me.

    Is it possible that my image was corrupted or improperly mounted to my usb key?

    The partitioner did work, so my previous Kali install was removed.
    I've been trying things with the installer, but I honestly don't know what I'm doing. (I just started the Kali class)

    Does anyone have a solution to this?
    Thanks

  2. #2
    Update:

    I went out to a restaurant to test the installer using their wifi, the network configuration worked and I was able to go through the rest of the installer. Some grub packages were downloaded during the process. It seems my home network was the cause of the network error.

    However, after a full reinstall, including what appeared to be a successful grub install, Kali does not boot. I get a loud beeping noise (thanks dell) with a BIOS error message. I went through the boot menu to manually select kali, the same thing happened.

  3. #3
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    1,012
    Set boot order in BIOS settings.

Similar Threads

  1. Kali Linux total install failure ver 2019.2 as native OS
    By czech_m8 in forum Installing Archive
    Replies: 3
    Last Post: 2019-06-06, 18:07
  2. problem installing grub (kali linux light X windows 10 )
    By belheart in forum Installing Archive
    Replies: 1
    Last Post: 2018-12-12, 02:48
  3. GNU Grub version 2.02 Failure Grub Rescue (Kali Linux)
    By rajesh_pratap in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-04-15, 17:40
  4. cannot install hydra on kali 2.0 light
    By Noooob88 in forum General Archive
    Replies: 0
    Last Post: 2015-09-12, 11:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •