Results 1 to 1 of 1

Thread: Problem to complete installation of openvas

  1. #1
    Join Date

    [SOLVED] Problem to complete installation of openvas

    I have Kali 2019.4 installed into a Virtualbox machine (4GB, 2-CPU) fully updated and upgraded.

    I'm trying to install openvas directly from the Kali repository (apt install openvas) as root, but it is not able to complete the installation process.
    After downloaded and unpacked, during the "processing" stage (at around 97%), the installation gives the follow error:
    Setting up openvas-manager (7.0.3-1) ...
    Creating openvas-scanner's certificate files
    ERROR: Failed to create self signed certificate, see /tmp/tmp.dqbpol09MD/openvas-manage-certs.log for details. Aborting.
    dpkg: error processing package openvas-manager (--configure):
     installed openvas-manager package post-installation script subprocess returned error exit status 1
    Setting up openvas-cli (1.4.5-2) ...
    Setting up openvas-scanner (5.1.3-2) ...
    update-rc.d: We have no instructions for the openvas-scanner init script.
    update-rc.d: It looks like a non-network service, we enable it.
    dpkg: dependency problems prevent configuration of openvas:
     openvas depends on openvas-manager (>= 7.0.2-4); however:
      Package openvas-manager is not configured yet.
    dpkg: error processing package openvas (--configure):
     dependency problems - leaving unconfigured
    Processing triggers for desktop-file-utils (0.24-1) ...
    Processing triggers for mime-support (3.64) ...
    Processing triggers for gnome-menus (3.32.0-1) ...
    Processing triggers for libc-bin (2.29-2) ...
    Processing triggers for systemd (242-7) ...
    Processing triggers for man-db (2.8.7-3) ...
    Processing triggers for fontconfig (2.13.1-2+b1) ...
    Processing triggers for tex-common (6.12) ...
    Running updmap-sys. This may take some time... done.
    Running mktexlsr /var/lib/texmf ... done.
    Building format(s) --all.
        This may take some time... done.
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    If I check "/tmp/tmp.dqbpol09MD/openvas-manage-certs.log" I have:
    Generating a 3072 bit RSA private key...
    configFileLoad: No such file or directory
    Error loading template: /tmp/tmp.dqbpol09MD/caopenvas-cert.cfg
    OK, I check "/tmp/tmp.dqbpol09MD/caopenvas-cert.cfg" then:
    expiration_days = 3652
    country = "DE"
    locality = "Osnabrueck"
    organization = "OpenVAS Users"
    unit = "Certificate Authority for kali.' " ' ' "
    But here I don't know what to check...

    Country and locality are wrong (I'm from Ireland) but maybe they are a default value.
    Looks like "unit", "ca", "cert_signing_key" and "crl_signing_key" are not set but maybe at that moment the installation was interrupted.

    Can somebody help me?
    Or at least let me know what do I have to check?


    I have reinstalled Kali and the issue doesn't appear anymore.
    This time I used the official ISO file instead the official vagrant file (maybe this was the reason).
    Last edited by two_socks; 2019-10-24 at 16:41. Reason: Set post as solved

Similar Threads

  1. Complete installation on USB-SSD - Can't see the disk
    By Perceval in forum Installing Archive
    Replies: 1
    Last Post: 2016-11-20, 10:24
  2. Replies: 1
    Last Post: 2015-07-05, 14:38
  3. Kali does not boot after complete installation on virtuall box
    By Mikeproject2009 in forum Installing Archive
    Replies: 1
    Last Post: 2015-06-14, 22:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts