Results 1 to 3 of 3

Thread: Armitage et MS16-032 CVE 2016-0099

  1. #1
    Join Date

    Armitage et MS16-032 CVE 2016-0099

    I use 2 VMs
    First VM with kali
    Second VM with win 10 1511

    The VM win is vulnerable and I exploit cve 2016-0099 localy with pwershell script.
    And test is ok -> I've create admin user

    Now I would like use this vulneralibility with kali.

    1 - run VMs
    2 - login on kali
    3- run armitage
    4 - hosts - nmap scan - quick scan
    I found my VM win10-1511
    5 - attacks - find attack -> nothing
    6 - Armitage - set exploit rank - I've select poor
    7 - again 5 -> I see menu appear but no electric on my host
    8- I search ms16-032 -> exploit/Windows/local
    9 - run with default options (no session can be select) -> exploit failed : the following options failed to validate : SESSION

    I understand that I must be have the SESSION

    Could you explain to me ?

    Thank (sorry for my english)

  2. #2
    Join Date
    Having the same problem I'm running mine for real though this is an answer not a good one I tried it on my home network it works I was able to exploit an old Galaxy J2 I had in a drawer collecting dust, like I said it works somewhat. Before anyone takes my head off it is the only answer I could find, I still can't get nmap or Armitage to show all the devices and neither will show any type of Windows machine. They do find Linux. This is actually really bad because Fing on the Play store actually works better than nmap or Armitage when it comes to finding the devices. I hope I don't have to tell you this but just in case don't go signing your phone onto networks that aren't your own, you don't need that coming back at you the router keeps logs some routers better than others so it really isn't a good idea. If you would decide to use Fing get a burner. I have found this issue multiple places so I know it's not just me. I've tried everything nothing fixes it I got the Fing idea from another post Stack Exchange just google How to find live hosts on my network I'm pretty sure that's the Fing one if not I have it saved just let me know and I'll supply it. Like I said this isn't my idea and it isn't a very good one it doesn't solve the problem just makes it a little better. Downgrade the attacks. Click Armitage where it says level of attacks or whatever it is down grade to the lowest. It will at least show exploits when you pick the target most likely every exploit in existence but at least it does something instead of sit there.

  3. #3
    Join Date
    Sorry I miss read your post. Didn't see the part where you said you did that. Sorry again, I got nothing for you never had that problem but I don't use VM because I have only had problems every time i try one. My advice use an old device like I did then at least you'll know how to do it for real instead of setting up a VM to fail. So what if it's hard and takes a lot of effort to get it at least you accomplished something. Anyone can win a race if you break all the other runners legs. Have fun.

Similar Threads

  1. Replies: 1
    Last Post: 2017-04-08, 13:27
  2. Fresh install on proxmox works with 2016.1 but not 2016.2
    By meepmeep in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2016-10-17, 09:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts