I recently bought a gaming PC for school and cybersecurity research. When I try to dual boot Kali with windows 10, it gets stuck on "Resuming from Hibernation". I commented out the swap partition id from /etc/fstab. I tried to install it again when the boot was stuck at checking all my filesystems. It displayed fsckd-cancel-msg : Press ctrl+C to cancel. But ctrl+c didn't work. So, to disable checking all the file systems, I edited /etc/fstab by changing the partition column from 1 or 2 to 0. Apparently, my root and home partitions had a 1 and a 2 flag which caused the file system to check. Now when I did that, its just stuck displaying [OK] Started GNOME Display Manager and its just stuck there and didn't boot. My config for the PC are as follows:-

CPU - INTEL core i5 9400f

Apparently, i5 9400f comes without integrated graphics and I think linux has a problem booting without it. So, to see if its boot without an integrated gpu, I edited grub by replacing "quiet" with "nomodeset quiet splash" and when that didn't work I replaced that with "quiet nouveau.modset=0" to disable nouveau driver.
When that didn't work, I thought maybe its GDM 3 problem. To resolve that, I tried installing lightdm. But apparently, apt-get install didn't work and displayed an error message saying unable to locate the package lightdm. So, I edited my sources.list and replaced it what was on the official site. But the problem still existed.

To see if it was some bug regarding dual booting kali, I installed it on my laptop with an integrated gpu and it worked. I was able to use kali as usual. To see my gpu had some problem communicating with the os, I tried using Kali Linux in Virutal Machine. And, yes it worked. Kali on VM runs just fine. So, I guess this is the integrated graphics problem. I tried to download latest NVIDIA drivers on the machine but it seems it was already up to date but worth mentioning some of the drivers were not found. Like when I did apt-get install nvidia-drivers. The package was not found. Now, I'm stuck where I started at boot logs. Any help would be appreciated